Showing results for 
Show  only  | Search instead for 
Did you mean: 

Driver Download


In attempting to download and install drivers and software for my Pixma MG7520 to a Dell XPS13 notebook running on Windows 10, I received the error message "Can't create output file"


Product Expert
Product Expert

Hi K-10,


To resolve this error, please follow the steps from the following Knowledgebase Article:





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

When I right click on file, my only options are:

Copy link

Show in folder

Report this download as unsafe


No option to re-name.

In addition, when I go to the location on my notebook of my downloads, it is not there.

It is located in C;\Users\kten1\AppData\Local\Temp\win-mg7500-1_0-ucd\MSetup4.exe


Have I not completed the download? I don't see any other options.

Product Expert
Product Expert

Hi K-10,


Based on the file name, I recommend trying this with just the printer/scanner driver not the full software. Please click the link below to download the MG7500 series MP Drivers Ver. 1.01 file. Then try the steps again that Patrick sent you.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



Thank you for your reply. I followed your instructions and renamed the downloaded file to a .zip file and extracted it and got the setup file but each time I selected the next step, the new page got smaller and smaller. When I got to the "Select the printer connection method", I selected wireless LAN but there is no visible button to select "OK" or "Next" or "continue", I think they are off the visible page which is only about 2" square and I can't enlarge it. I think you have the correct solution but somehow the program or my laptop (it couldn't possibly be the user) are misbehaving.


Recently I got the same error message. I tried to solve the problem in different ways for a very long time, but nothing helped me at all.One day the idea came to me at my own risk to try to download drivers from a torrent. I went to Pirate Bay and found just what I needed. And for a long time now, no problems have arisen


Greetings K-10.  You are on the right track.  As you have discovered, you cannot click on the Download menu in your browser and get the same (right-click) context menu options.


You need to rename the file by navigating to the folder where it was downloaded or saved.  Sounds like you were able to get past this as well.


All you are basically doing is performing the extract option manually by changing the file type from .exe (self-extracting Zip) to .zip and manually extracting its contents.

I have seen posts from others stating that they were not able to see the save or next button of a installer dialog.  You can likely resolve this by temporarily changing the screen resolution in Windows Display Settings.  Right-click on a empty portion of your desktop and adjust to a resolution lower / higher than what you might have now.  This should help you manipulate it.  You can change it back once you've completed the install.  





Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It