Showing results for 
Show  only  | Search instead for 
Did you mean: 

Code 5,157,69 - MG5520


I have a PIXMA MG5520 printer.  The printer works, the copier works, but when I try to scan, I get a Code 5,157,69.  I have uninstalled and reinstalled the software, but nothing seems to work.  So my guess is that there is a setting which somehow got changed.  Please help.



I was getting the same error and tried un-install / re-install, which didn't work.  Then I turned of my work VPN to see if that was the issue and it was.  As soon as I disconnected the VPN it worked again, so the first couple of times I used the scanner I must not have been on my company's VPN.  Hope that helps!

View solution in original post



Hi LauraKosmos!


To have a better understanding of your issue, please let everyone know what operating system (Windows Vista/7/8 or Mac OS 10.X) you are using. That way, community will be able to assist you with suggestions appropriate for your product.
If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team.



I'm running Windows 7, and the connection is WLAN.

I currently have a problem with my Pixma MG2922 where the scanner won't start. I have a Windows 10 laptop; what's a solution to the problem i am currently experiencing.

Hi Carlos75,


Are you using your PIXMA MG2922 with a USB cable or are you using your PIXMA MG2922 wirelessly?


Do you get an error message when you attempt to scan?  If so, what is the exact wording of the error message that you get?


Please note, Canon's Forum is not intended for immediate help, but a place to allow for the Community to give you assistance and feedback. If this is an urgent support need, please use the link below to reach our friendly Technical Support Team:

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm having the same issue with my MG2922.  I haven't used the scanner since I moved, and it worked fine before.  I have a VPN, I disabled it and basically shut off all of my virus software to no avail.  


What is the work around?



Cannot communicate with the scanner for thrse reasons:

-Scanner is turned off

-(if using wired LAN connection) it is disconnected

-(if using wireless LAN connection)signal strenth if poor due to obstructions

-network connnection is prohibied by security software

-different scanner on the network is selected





I don't use the wireless feature, I'm hooked up by a cord.

I've turned off everything that uses the enternet except my computer plugged into the printer

internet is working just fine

I shut off all my security and tried a few restarts with no security, I even checked that my system is all up to date. I'm out of ideas and tired of trolling the community



Hi LauraKosmos,


You will need to have the Canon IJ Network Scanner Selector running on your computer in order to scan wirelessly. To ensure it is running, from the Start menu on your computer, select All Programs, then Canon Utilities, then IJ Network Scanner Selector EX (folder), then IJ Network Scanner Selector EX (program). When launched, the icon appears in the notification area of the taskbar.  You can also try temporarily disabling any antivirus or firewall software that is on your computer, as these programs sometimes block the scanning process of the printer.  If you still experience difficult scanning, please call or email us using one of the methods on the Contact Us page for further assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have tried everything you have suggested, except temporarily disabling the firewall and antivirus software.  I have decided not to do this and bought a USB printer cable and am now scanning through Devices and Printers because it still doesn't work as you have advertised.  I bought the printer because it was wireless and am very disappointed with it.  I could have bought a $40 printer that does the same thing.

Oh and by the way, I did send Canon a message for a solution through e-mail about a week and a half ago (for which there was supposed to be a reply within 8 hours) and have yet to hear a response.

Hi LauraKosmos, 


If you would like to continue troubleshooting the wireless scanning issue, to see if the scanner is being recognized by the computer, I would like to have you try and scan from the Microsoft Paint program.  To do this, please follow these steps:


1. Go to your START Menu, select ALL PROGRAMS, then ACCESSORIES, then MICROSOFT PAINT.

2. Once inside of Paint, in the upper left corner you will see a blue square; please click on that and select FROM SCANNER OR CAMERA. A window will appear asking you what device you want to use. Please select your printer, then press the OK button.

3. In the next window, you should have the option of selecting a document type; please select one, then press the SCAN button in the window.  Are you able to scan wirelessly successfully using Microsoft Paint?


Also, if you still have not received a response via email, please check the SPAM or Junk Mail folders of your email program, as sometimes emails can be received and end up in those folders.  You can also call us at the number on our Contact Us page and a representative will be happy to assist you via telephone.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
click here to view the gallery