Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Quick Menu Won't Start


I have an MG7720 printer/scanner.

When I reinstalled the drivers for it, the Quick Menu stopped working.

There is no error message or notification that appears, it just won't start.  It does not load at start up either, even though its in the startup list.

There does not appear to be a Twain driver conflict as the only thing in Windows/twain_32/ is wiatwain.ds and the SG20 folder the Canon drivers installed.

I've tried uninstalling and reinstalling the full driver package >10 times with the same result.  Everthing works except the Qucik Menu.  If I use the IJ Scan Utility, the scanner works fine.

There is some conflict with the Quick Menu utility.  Does anyone have insight into what the Quick Menu is doing when it starts, and how I might debug this.




Have you downloaded the latest version of Quick Menu (2.8.5)

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Yes, I have tried installing that separately, same result.

Hi yellowhaus,


Since there was no conflict in the TWAIN_32 folder and reinstalling the drivers and Quick Menu did not resolve, I recommend you contact our support team. Please click HERE for our support page. If you have not created a Canon Account, please click HERE.


We look forward to hearing from you.