Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MG6620 new printerhead, still get error 1403


Hello.  I have a PIXMA MG6620 printer and I got an error message 1403.  So I bought a new printer head and installed it.  I am still getting an error message 1403.  I turned it off and back on, still no luck.  What am I doing wrong?




Product Expert
Product Expert

Hi Jztcastiglia,


Please take the inks out of the printer and then put them back in making sure they click into place. Once that is done, I recommend performing a reset of the printer. While the printer is on, unplug the power cord from the printer and let it sit for 60 seconds. While the power is off, press the power button 5 times. After 60 seconds plug the power cord back in and power on the printer. 


If the error does not clear after the reset, the printer has experienced an internal hardware issue.


If the printer is out of it's 1 year warranty, you would qualify for the Canon Upgrade program. This is for out of warranty units which have been diagnosed to require service or are incompatible with a new or upgraded system. This program allows you the opportunity to purchase a replacement product discounted from the list price. Free ground shipping is included with your purchase.


If you would like to take advantage of this offer, please call our Sales Department at (866) 443-8002 mon-Sat, 9 AM to 9pm EST. Let them know you have been working with technical support and that the Canon Upgrade Program was offered.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



Unfortunately no.  I followed instructions to a T and I still get an error message. It appears that my printer is finally broken.  I had it for 8 years, it had a great run!  I would like to try that discounted upgrade system that Canon offers, however I bought a large number of ink cartridges for my printer so now I have to find one that uses the same type.