Showing results for 
Show  only  | Search instead for 
Did you mean: 

Call to Arms for the dreaded U052 Wrong Printhead Error


This is a "call to arms" for all of you Canon customers who have had this problem and have had their printers disabled because of it.  Please respond with the model of your printer and if you were able to fix it, what you did to fix it. 


We need to put pressure on Canon to respond this product defect.  It appears to be bad firmware that does not allow the user to override the problem and to continue to use the printer even in a degraded mode.  From my investigations the problem is NOT a printhead issue - no way one can be printing fine and then have this error alert without having changed the printhead or ink cartridges!


Canon, PLEASE take this issue seriously and provide a solution across the affected models.  If nothing else there should be a trade-in allowance for those printers that have been affected by this product defect.


I have had many Canon printers because they have superior functional specifications. I want to be able to continue using Canon products but only if I can have confidence that this product defect will not destroy my investment.


If Canon is unresponsive our next step should be to aggressively publisize this product defect on social media and on major product vendor outlet sites as negatives reviews.


Forum Users, please reply with your affected model number(s) and with details of any succdessful fix procedure.

1,478 REPLIES 1,478


The print head is not the problem.   After getting that message on my printer, I bought a different Canon printer that used the exact same identical print head.  I took the printhead out of the brand new printer and put it into the old printer and still got the same message. I'm 100% confident that the printhead is not the problem.




I had an MX922. Tried everything suggested but no luck.  I no longer have the printer. I couldn't see taking up valuable desk space with a pile of useless plastic.



Add another to the pile.  Smiley Tongue


Got the U052 error on my MX892 last week.  Been looking for a solution, reading through this crazy long forum topic only to find that nothing seems to work to fix it.   Maybe there are solutions I've not yet tried (outside of ordering a new print head which I'm told rarely works to fix the problem).


This printer is at least 2 years old, so presumably out of warranty.   The error popped up after a power outage, which of course shut the printer off non-gracefully.   The printer always complained about not being shut down properly when it would boot back up,  but it's gone through at least a dozen power outages in the time I've had it, and this is the first time it decided to give me the 052 error when the power came back on. 


The worst part about this is that I use the scanner WAY more often than I actually use the printer part of the machine.   In fact I need to scan things now, but.... I can't.   Apparently because there is a problem with the printhead (or so the printer believes),  I am locked out of using any other functions like the scanner. 


Ugh.   So... now what do I do?   Unless I can find a solution that works I guess I'm forced to buy a new machine at the very least to do my scans. 




The only solution that most of us have found is to dump the Canon printer and purchase a different brand printer.

A new print head won't fix the issue so put that money towards a new printer.

Canon just doesn't care.

Just received error 1403 for the first time on my MG7120. It appears to be related to your post. Has there been any progress on fixing this Canon related issue?


Same problem here with a printer that was otherwise working ok for years. Hard to believe how long this thread has been going on.  I bothered to register on this forum just to post a reply so Canon knows they lost yet another customer.  I get problems can happen to any piece of equipment from any company. But this is an obvious defect and not owning up to shows a lack of integrity.  We had this one printer with the print head problem and actually have another canon. And we've had others in the past. Will not buy another one out of principle. So long Canon. 


Once this message appears, the printer is trash. Going out today to buy an HP.


I was just trying to print out some documents for a legal hearing this morning and I got this error.  I'm so ticked off.  I tried the reset instructions but it doesn't work.  This printer is not even that old.  Just out of the blue it has the wrong printhead.  I haven't changed the printhead.  Is there a class action suit on this?  If so I want in.  I have to run up to the fed ex store and print these off so I can have them for the meeting in 3 hours.  I don't have time to go out and buy a new printer and set it up for this. 




This is still happening in 2019! Different code: 1403 instead U052, but same reason. Printer MG6650



Same issue with a MG6650 multifunction printer. None of the suggested solutions has worked so far. Not willing to buy a print head to see if that works.

click here to view the gallery