cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

canon camera connect on android 13 issues with canon g7x II

nicoldy
Apprentice

Hello,

I have g7x II with latest firmware. It is connected and used without any issues with two android phones (Xiaomi devices) with android 10 and 11. There is a problem with another Xiaomi device with android 13. It  connects successfully (manually and via nfc) with the camera in the app but when 'Import images' (or 'images on camera') is selected there is a message 'no images on camera' in the app. On camera screen the message is 'disconnected'. I assume that connection drops for some reason when this option is selected ('Import images'). But this is not always. Occasionally every once and a while connection is stable and images are shown. This happens once in ten attempts (reconnects). The issue is only with this menu. When 'shoot' is selected it works perfectly every time. Also when connection is established and i use camera to select and transfer images - there is no problem either.

Done so far - resetted  wifi settings on camera and on phone, cleared app data, deleted app, rebooted phone, freshly installed app several times, cache cleared and all that i could think of in different sequence and combinations with no success. No matter what i did the result is consistent with the described above. 

As i run out of options and had no luck with googling this i really hope that someone here could have idea what is causing the problem and to find solution for it.

 

Thanks in advance!

BR,

NN

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

There as been an above average number of reports (recently) about connection issues with the CC App over Wi-Fi, using Android.  I have a pixel6 and 8, both are running Android 14, with the December security patch.  I have zero issues, connecting, controlling or transferring.  I just enable Wi-Fi and open the App.  It detects the cameras broadcast 100% of the time.  I'm at a loss as I am unable to reproduce the issue reported by others.  I didn't have issues with Android 13 either, when using earlier versions of the CC App available at the time. 

You are the first person who's mentioned a problem when switching from bluetooth to Wi-Fi for image transfer. I don't have a way to test with Android 13 unfortunately, but I will try starting with bluetooth and switching to Wi-Fi for transfer.  I have not had issues in the past doing this.  Normally I just connect to Wi-Fi from the start when transferring photos.       

I understand the problem you are experiencing only occurs when you switch from Bluetooth to wireless for image transfer in app.  When performed manually it works.  It fails 9 out of 10 times when you try to switch for image transfer.  You also stated it works once out of every ten attempts.  Then images on the camera can be browsed and transferred.  I'll see what happens, but thus far the connection and transition between both connections is seamless for me.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Unfortunately, I could not reproduce the behavior.

Bluetooth and Wi-Fi enabled on camera

Start connected to Bluetooth

shadowsports_0-1704648507096.png

Press Import Images button.  App switching from Bluetooth to wireless

shadowsports_1-1704648593504.png

App automatically detects Wi-Fi broadcast on camera, tap to connect

shadowsports_2-1704648679738.png

App now connected to Bluetooth and wireless.  Images can be browsed and transferred. I also tested remote shooting.

shadowsports_3-1704648864868.png

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

nicoldy
Apprentice

Never turned bluetooth on when using the app and facing the issue.  This interface by default is off, as i am not using it. I am always using wifi connection and the problem appears only when selecting home-->'import images' or functions -->'images on camera'. If i don't click these options, wifi connection stays on and i can use the app as a remote control or to transfer images but only if i use the camera to select and send them to phone.

I just turned bluetooth on for first time before using the app to see if it will make any difference.. It didn't.

 

p.s. i am not even sure if the camera (canon g7x mark II) features bluetooth connectivity.

p.p.s

just tried connecting over home wifi network and there was no problem 5 out of 5 times.The described issue appears only with direct connection to camera's access point wifi (hot spot).

p.p.p.s.

finally, a breakthrough!

in camera settings --> wireless settings--> wifi settings --> I set  password 'off'. After this  5 out of 5 times there was no problem accessing images in the app. This doesn't seem like a very good solution but at least it is a workaround.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements