Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with EOS utility Autoupdate services and SSL certificate




I have an EOS750D and normally you can send pictures through the WIFI but you need to register for some services and you do that with the Web services registration tool.

There is an auto update service that needs to run but mine is crashing as it is not starting directly the software. Then it cannot update the SSL certificate.


Does it sound familiar to anyone and what should I do to make it work again ?


Thanks in advance for your help ?


Heph51SSL certificate.jpgAuto update service.jpg



I have exactly the same issue with my brand new EOS 2000D / Rebel T7.  However, i'm trying to register to


I can do everything else, even conect to Lightroom and import images, I've updated the firmware, I have even checked that the programs have access through my firewall and the do. But nothing has helped.


AND I HAVE NO VIRUS! Not even Coronavirus Smiley Tongue


Did anyone ever resolve the issue??



Hi there,


Is EOS Utility giving you the SSL certificate error or is it coming directly from One thing I would recommend just in case is attempting the registration through a different web browser, maybe even in the private browsing/incognito mode so that you know there are not conflicts with anything in the cache.

Yes, it's the canon utility/web registration tool that's giving the error, not the web browser.

It is directly asking for the latest SSL certificate to be installed on my camera.

Hi dpartonginno,


In case you haven't done so already, I suggest that you download the latest version of EOS Utility. You can do that by visiting


On the new page that loads, click on DRIVERS & DOWNLOADS link on the top right. Enter your camera model in the prompt, select it from the options that load under the box, and then press the GO button. Then download the latest version of EOS Utility, unzip the file, and then install it.


If problems persist, please elaborate on what version of Windows you are running and what kinds of anti-virus and/or web-security programs you have on your computer.

Hi Nick2020.
I have only just purchased the camera so the utility is the latest.
I've updated the firmware for the EOS 2000D from Vr. 1.0.0 to 1.0.1

I am running Windows 10 home addition with the built-in anti-virus / firewall Windows Security Center (previously called windows defender)

I have checked and all traffic for any canon related software has in/outbound access and the definitions are up-to-date.
I also regularly run a malware scan and nothing is present.

I updated the firmware because the utility didn't work with the previous firmware either

If you've followed the suggestions of the Subject Matter Expert (SME), and you're still having problems, we suggest reaching out to support for one-on-one assistance via your My Canon Account at


If you're not in the USA, you'll find contact information for support in your country HERE.

Thanks Stephen I have but nothing so far

I am having the same problem with SSL certificate error trying to connect my Rebel t6i/750D to the EOS Utility software - Camera Settings - Web Service Settings. I get a "The latest SSL certificate is available. Download and set up on the camera.". Then "Configuring on camera...". Then "Error The connection was lost". And I see the unaccessible "Login to Canon Image Gateway behind the last error.

After the announcement, I have been trying to set that capability on my camera, with no success. I have consulted various sources:

Troubleshooting section of EOS Utility manual from Canon:
- System Reqt's Checked (Utility software downloaded from Canon site for current MacOS Catalina)
- Loose plug (Plug doesn't fit as snug as I would expect, but I've tried other cables and they all fit similarly)
- Camera's Power On (Switched to On, but I have noticed the screen turns off right after the SSL error)
- No hub used (I still need to use a dongle since it's Mac, and I've tried the single and triple connection dongles)
- Other USB devices (Nope)
- More than one camera (Nope)
- Linked Shooting WFT issue (Nope)
- Insufficient Battery Charge (Freshly charged)

Canon online FAQ (Connecting a camera to a computer...):
-Disable Auto power off on camera (Done)

Other forums:
- Disable WiFi/NFC (Disabled)
- Use original cable (I used a recently purchased cable from Canon website - No luck)
- Download software from disc during purchase (I get an error: "Setup" needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information."
-Remove SD card (I haven't tried this one yet)

As you can see, I've exhausted my options.

Not much help from Canon Support so far.


Thank you for your reply.

This is a strange error which I haven’t come across before, and as such may be the result of a faulty install of EOS Utility. Please follow the instructions below to uninstall and then reinstall the latest version of the EOS Utility which will hopefully resolve the issue.

  1. Click on start, and type in “Apps and features”, open the Apps and Features system settings application
  2. Search for EOS Utility, select and uninstall EOS Utility 2 and EOS Utility 3
  3. https : // www . canon - europe . com/support/consumer_products/products/cameras/digital_slr/eos-2000d.html?type=software&softwaredescriptionid=tcm:13-1330031&os=windows%2010%20%2864-bit%29&language=en to access the webpage to download the latest version of the EOS Utility
  4. Run the installer as an administrator

I hope that this resolves the issue, however if it persists, please do not hesitate to contact us again.

Yours sincerely,

Unfortunately the issue persists!

click here to view the gallery