cancel
Showing results for 
Search instead for 
Did you mean: 

I want to use DPP 4 and the EOS utility for tethered shooting.

secondlevel
Frequent Contributor

I have a shoot coming up and i want to use the EOS utility and DPP 4.  I like the improvements on DPP 4.  However, the EOS utililty that came with my EOS 60d is not compatible with DPP 4.  I went to the Canon website and the downloaded the EOS utility updater and I still get an error message from DPP 4 that says a compatible version of EOS utility is not installed.

7 REPLIES 7

RobertTheFat
Honored Contributor

secondlevel wrote:

I have a shoot coming up and i want to use the EOS utility and DPP 4.  I like the improvements on DPP 4.  However, the EOS utililty that came with my EOS 60d is not compatible with DPP 4.  I went to the Canon website and the downloaded the EOS utility updater and I still get an error message from DPP 4 that says a compatible version of EOS utility is not installed.


Get the latest release of EOSU V3, and install it from scratch. The installer will install both V3 and V2, together with a dispatcher that automatically chooses to run the one that is most compatible with the camera.

 

Also, make sure you have the latest release (4.5.20) of DPP4 installed. It came out in the U.S. only about a week ago.

Bob
Philadelphia, Pennsylvania USA

When I go to the Canon website and enter my camera I don't get the option to download the new version of the EOS utility.  I searched the Canon website but couldn't find a link to download it.

It might be that DPP4 only works with EU3. It is possible to have both EU2 and EU3 installed together, so you could download via EU2/DPP3 and then switch to DPP4 for processing.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

screen shot.jpgI can't find an option to upgrade in the software or a link on the Canon website.  This is what I see when I login to downloads:

 

 

You won't see EU3 since it's not compatible with your camera. Install EU 2 update and DPP3. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic


@jrhoffman75 wrote:

You won't see EU3 since it's not compatible with your camera. Install EU 2 update and DPP3. 


OTOH, you can pretend to have a higher-level camera and download and install EOSU 3 instead. (I don't think you have toi provide a serial number for an EOSU download.) The way EOSU works is that if you install EOSU 3, EOSU 2 is installed as well. If you then call EOSU 3, the software will decide whether your camera prefers EOSU 3 or EOSU 2 and will start the correct version.

 

As for DPP, recent versions of DPP 4 do support the 60D. The Web site should accept your 60D serial number for the download of DPP 4.

Bob
Philadelphia, Pennsylvania USA

secondlevel
Frequent Contributor
Thanks for the reply.