Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Utility problem


Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy


I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck

View solution in original post

132 REPLIES 132


 I am running Win8 (upgrade from Win7) and EOS Util 2.11.40 / 5D MKIII and it works - should I not upgrade to 2.12? Smiley Surprised


Update:  I updated to all the latest Software, IBEX, DDP, and EOS Util.  It all still works fine - camera control / shooting, etc.


As a side note to anyone from Canon reading this - the updates don't show the latest firmware when I select Windows 8 x64 as my OS.  That's probably a site error as the firmware updates have nothing to do with the OS and only the camera - they should probablt show up for all Operating Systems.


I also cannot get Win8 x64 to connect to EOS Uitility.  I've tried it on two PC's running Win8, neither work.   Works fine on the same hardware with Win7 or xp, in fact I'm running both on a virtual machine (vmware) and attaching the driver to the VM works OK.  Basically MTP portable device drivers get loaded and it just looks like a flash drive - but EOS Utility can't see the camera.


Canon is aware that it works for some people and not others according to the various posts that are showing up on dpreview, canonrumors, and fredmiranda.  Eventually they will have to figure it out.

I tried on other PC with Windows8 and it work !
I think it is some drivers incompatibility, becouse when I started the OS and I don't wait it loading all drivers and I run quickly the EOS utility , it work ! But I have to be very fast! Try it


In the Device Manager, I get a Canon 5D III under "Portable Devices" and it shows up like that in the same area when I explore "My Computer".


What shows up in your Device Manager when you connect the camera?


In my device manager is all OK. I can see the 5DmarkIII icon and in property panel it says me that the device works fine and all drivers are installed.  Man Frustrated


I have the same problem.

I have removed the software, switched off and reinstalled it.

Sometimes the camera (7D) will show up on windows explorer (under computer) and sometimes it wont.

I have check that I have .NET 3.5 installed.

So now I have given up trying to use EOS utility


I have the same problem with Eos Utility: will not download my photos. Recognizes the camera. Latest version of Utilities.Smiley Sad



I am sorry to read that you have difficulty with Windows 8 and EOS Utility.  Version 2.12.0 should allow you to connect to the EOS 5D Mark III on that platform.  Since you mention other computers being able to connect without an issue, it must be something specific to your machine.  I would try uninstalling the software and then starting again from scratch.  Install the Utilities off the CD and then update off the web site. 

I hope this helps resolve the issue.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hey Tim - There are many of us with this problem on Windows 8 x64. I have two systems that don't work no matter what I do (uninstall / reinstall etc).  The MTP driver gets loaded as if it is a flash drive, which works fine, but EOS utility cannot see the camera.  I've tried two such x64 systems, and they both behave the same.  I've attached the driver dialog box snapshot below.


Your guys at Canon R&D need to try a few different physical installations and I"m pretty sure you'll find that there's some sort of driver problem.



click here to view the gallery