Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Utility problem


Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy


I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck

View solution in original post

132 REPLIES 132

@kvbarkley wrote:

Download a fresh archive and re-install.

And when you do, remember this: If you're on a 64-bit Windows OS, install Version 3 of EOSU, even if you don't think your camera can use it. Installing Version 3 causes the installation of both versions (2 and 3). Then when you call up Version 3, it will determine whether your camera needs Version 2 and automatically call it up if it does. For some reason Canon describes this process in only the vaguest of terms, and users' misunderstanding of it is the basis for many of the problems reported regarding EOSU in the past two years or so.

Philadelphia, Pennsylvania USA


I'm at a loss. About a month ago the Eos Utility stopped working. I was using version 2 since my update to windows 10. Since then, everytime I try to use it, I get the lovely message that a "problem" has occured and caused the utility to stop working. I have tried uninstalling it, reinstalling it, uninstalling windows updates, unplugging everything that was plugged into USB ports, installing utility 3, uinstalling utility 3. I'm at the point where I'm ready to throw my computer and camera out the window.


Now on that note, I really only use the utility for the downloading images and the organization aspect of it. So I guess my question is this....Is there a way to fix the utility so it actually works or does anyone have different program they use to download and organize their pictures?



Hello Canon World.


i need a small help from you ...i have issue with the upgrading firmware as mentioned below. i have already formated 1.2.5 and now i m triying to upgrade or upload new version. but when i clicked on the setting menu firmware to be upgraded in not highlighted. 


utility error.jpgutility error.jpg

Hello BOY, 

We recommend uninstalling the EOS Utility application and reinstalling fresh from the web site.  Then try reconnecting the camera again. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


Crisis. In Costa Rica with my D5 MKiv. First error message: Invalid correction data for Digital Lens Optimizer. Use EOS Utility to replace the correction data.


Removed and replaced EOS Utility 3 (Mac). No help.


Updated firmware. No effect.


Tried a shot. Second error message: Err 70 An error prevented shooting. Turn the camera off and on again or re-install the battery. Done and done. Also changed batteries.


I am sorry to hear this happens.  We recommend filling out an online repair request form at the following link to setup your repair using our online service.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I am from Canada, in Costa Rica on a photo vacation. Is my vacation shot?

Hi, Knuk!  If you're based in Canada, we recommend contacting our colleagues at Canon Canada for support.  You'll find them HERE.


Hope this helps!

Is this a known problem? As I said, I am not in Canada. I am on an expensive Costa Rican vacation. My question is whether I am out of luck.
Sounds like.

Dear Knuk,

I had this problem once before (and I am not sure exactly how I solved it - but I will look up and come back to you), the problem is not with the Program EOS Ulitity, (therefore you can install it any number of times with no solution), the problem may be with your Computer, (MORE THAN ONE CAMERA LISTED ON YOUR COMPUTER or the same camera listed multiable times) your computer is not matching up your camera with the program, (you need to go into "control panel" and remove these extra cameras) so you have none, then restart computer and connect your camera again and all will be OK. HUGH