Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Utility problem


Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy


I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck

View solution in original post

132 REPLIES 132

@Kanitfastan wrote:

THX for reply.
Sorry, for not being exactly in my description. I never saw a BSOD, against that, the sys. has been freezing then.
The behaviour only occurs with EOSU, both versions I had in use, AND concurrently when the hw-interfaces overloaded. (WAN-remote control AND 30Mb via USB(EOSU).
The sys.-freezing is more or less no prob. The problem is only, that the EOSU-software afterwards crashes permanently at start-up with camera control. (As i wrote, I tried everything "usual" fixing. (see above)


If that occurs in the future, I will reset the system with Windows System Restore. Then it works again.


I do not agree with Microsofts (and yours) strategy, to update permanently. I follow the philosophy: Never change a running system.

I was a network admin, now I am retired. Since my last post I got 38,5GB via EOSUtility. I am avoiding freezing, by not storing to much data simultaneously.
THX for reading.


When you let philosoiphy dictate pracitce, you enter a risky realm. It's a truth whose implications extend far beyond computers and photography.

Philadelphia, Pennsylvania USA

Boston, Massachusetts USA


You can have this one.  Smiley Frustrated

EOS 1DX and 1D Mk IV and several lenses!


Hi, EOS Utility not working with Windows 10, the problem in the connection, when i run app, eos utility not see my camera, i click on the "Pairing over WIFI / LAN" and happens nothing


Hi senyafrost,


I have encountered a similar problem, even on Windows 8.  My solution was to (after connecting and turning your camera on) hit the Windows key on your keyboard, type "EOS", then find and launch a program called "EOS Utility 2".  This action bypasses the faulty launcher program and goes directly into the tethered software.


Please give this a try and let me know if it works for you.


Thanks and good luck!



Hi SloMoHolic, when i run EOS Utility 2, i have a crash, also i was trying to run with compatibility, and have the same


UPD, i saw your post from 10-09-2014 12:46 PM, and also this not helped for me


Sorry to hear that, senyafrost. 😞


My last recommendation for EOS Utility would be to disconnect the camera, completely uninstall the EOS Utility, uninstall and delete all drivers for your camera (using Device Manager as mentioned in my earlier post), and restart your computer.  Then, install EOS Utility, connect the camera, and hope for the best.


If that doesn't work, it may be that EOS Utility is simply unable to run properly on Windows 10.  Perhaps other users here may have tried it and can let us know of their results.


As an alternative, you may want to consider purchasing a third-party program, such as DSLR Remote Pro from Breeze Systems.  They offer a free trial download, so you could test it on your system before purchasing.  You can find more information about this software here:  [link removed per forum guidelines]


Best of luck!



Thank you, I've already done that, but that is no avail. I think yeah, EOS Utility is not unable to run properly on Windows 10.
But.. DSLR Remote Pro works fine, i didn't know about that app, thanks.


I have been using EOS Utility (supplied with camera) for approximately 1500 downloads and have been very happy to use the Utility software but, it seems that I have now joined the large number of users that have problems with the software.


Utility will not launch and I have tried various suggestions from Canon, including deleting the original disc software and replacing this with the very latest download from the net.


I have Windows 7, 64 bit and have been using FastStone, XnView and Gimp for many years and had these on my computer when I was downloading all of the 1500 images from my camera (this covered a period of several months).

My other image viewers will still download images.


I tried hitting the Windows key, typing in EOS and then clicking on EOS Utility 2 - nothing happens !

It is 'very' frustrating having a Canon EOS700D and not being able to use the supplied software.

Utility will not launch from Digital Photo Professional either.


If you can help me with my problem (bearing in mind that I am not a computer wizzz) I will be forever grateful.


My EOS 3 has never given me any problems like this and always gave me wonderful photographs.



It seems AVG is at fault.  You either need to disable AVG, or delete it altogether.  You can tell it to ignor several EOSU exe files.  Generally all of the executables.

EOS 1DX and 1D Mk IV and several lenses!

WoW! I temporarily disabled AVG and saw my EOS Utility for the first time in 3 weeks 🙂 Images downloaded fine.
Is there a free alternative to AVG that doesn't conflict with EOS Utility ?
Thank you very much for your help, this is greatly apprediated.
Enter for a chance to win