Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS3 utility USB connection fails on Win10/Ryzen - wireless normal


Hi folks,

Our firm has just upgraded our AV machine to an AMD Threadripper 2 2950X/Gigabyte X399 from an older Intel 5960X/Asus x99. Huge (and greatly appreciated) speed boost in everything we do, but can no longer connect a 5D Mk IV via USB connection. Software environment is a fresh install of Win10 Pro x64, v1809.


  • If EOS3 utility open and running before connecting camera, the main window flickers briefly before red text 'Connection lost' appears and the main window becomes unresponsive. The camera screen continues to show the 'Connected to PC' icon.
  • If the EOS3 utility is not open before connecting camera, upon connection the black EOS3 splash screen appears, but the application then hangs - a spinning cursor appears before eventually Windows detects that the app has crashed and it greys out about three minutes later.
  • When connected via USB and accessed via Windows Explorer, the camera is recognised by Windows and the directory structure of the CF card can be browsed, but Explorer immediately crashes and closes the window if the DCIM folder is opened.
  • EOS3 running on the same machine can connect to and download files from the camera via wifi connection flawlessly, with no bugs or other undesired behaviour. The problems occur purely when connected via USB.

Attempted troubleshooting steps:

  • Disable wifi on camera - no change
  • All USB ports - no change
  • All other USB devices disconnected (except mouse and KB) - no change
  • Uninstall and reinstall of EOS utilities from latest online version
  • Uninstall and reinstall of EOS utilities provided on-disc with camera
  • Verify that USB connection possible to older Intel-based machine using same cable - performs as expected
  • Uninstall all Windows driver entries for camera - Windows detects new device on next USB connection and reinstalls - no change

This problem appears localised to the new Ryzen-based production environment, as the EOS3 utility and camera are able to sucessfully connect via USB on the older Haswell-E Intel machine and, as a test, on a new-out-of-box Surface Pro 4.

Any further suggestions or troubleshooting steps to attempt would be greatly appreciated, as we shoot purely in large-format RAW and so the file transfer times via wifi are cripplingly slow and seriously frustrating.


Firmware update 1.3.3 solved the USB 3 problem with AMD Ryzen processor. Today I upgraded my camera and connecting to USB 3 works flawless

View solution in original post


Thanks for the suggestion - firmware is the latest available.


Give Canon a call at 1-800-OK-CANON.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Have you tried it with the cards in a card reader or in a different camera model? The answers might help narrow down the source of the problem, even if it's not feasible to change your workflow..

Philadelphia, Pennsylvania USA

I hadn't thought of trying the CF card in a reader - that's a good suggestion. We don't have one, but I'll try and pick up something cheap to test with.


I've been stuggling with this same problem for days, and I still have no solution.


It seems Canon has zero interest in supporting AMD-based systems. Pity!

I've been having the exact same problem. No problem whatsoever on my surface pro 4 or previous intel i7 system. It happens only on my new AMD x570 ultra with Ryzen 3900X. With a new lockdown coming up I wanted to try it again (cam as a webcam): updated BIOS, Eos utility and 5D IV to the latest firmware, but the problem remains unchanged. I'm going to try a wireless instead, but that might by less stable and slower for longer sessions.

@peterVC The fundamental problem is that Canon's software only supports Intel platforms. Period. They have no motivation for supporting AMD - probably due to a small, if growing subest of users - and will not put the time/money into it for the foreseeable future. This has been my conclusion since trying for weeks this spring to get it to work, and failing.


If you want to use your EOS camera as a webcam, your only option is to get an HDMI capture card, for example from Elgato. It's unfortunate, but that's just how it is.


As an update to all - I have been in contact with multiple parties (Canon, Gigabyte as mobo manufacturer, and AMD) over this issue, and have confirmed that the exact same issue occurs with other AMD chipsets. I have also received numerous messages from other parties affected by this bug, on these forums, Reddit, via forum posts and other venues - so if you've come across this thread, you're not alone.

After 12 months of back and forth, during which time Canon and Gigabyte disclaimed any responsibility, I eventually received this response from AMD confirming that this is a known issue:


This got bounced around a bit internally, but I have a quick update for you.


I received feedback that Canon has a custom chip inside which includes the USB controller for SD card/etc.


This means that in order to find the root cause, a reproduction of the issue in our lab using the exact Canon camera/hardware is required.


Our Dev team tried engaging Canon a few years back but got no traction, unfortunately. Therefore, we will need to procure a Canon 5D Mark IV separately to investigate.


I’m now waiting on engineering feedback on the feasibility of obtaining this camera and if not, what other options available to collect the information they need to debug the issue.


I appreciate your patience and will provide another update once I hear back from engineering.

I am in ongoing contact with AMD to try and get this resolved, however progres has been very slow. I would encourage everyone experiencing this bug to contact AMD themselves to try and get some critical mass behind getting this resolved - I would suggest you refer to service request 8200941155 and ask to be referred to Sean Iu.

That's great, but I need a webcam now with renewal of lockdown here for the next months. I won't be needing it in a couple of months/years.
I bought a budget webcam. It's OK, except GIF-like colors in Google Meet, precisely the app I need for work 😞 Also spent 20€ on a USB-C to A hub because that seems to have helped some, but not me. So 60€ spent and still no decent webcam. Thanks Canon/Gigabyte
click here to view the gallery