Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS3 utility USB connection fails on Win10/Ryzen - wireless normal


Hi folks,

Our firm has just upgraded our AV machine to an AMD Threadripper 2 2950X/Gigabyte X399 from an older Intel 5960X/Asus x99. Huge (and greatly appreciated) speed boost in everything we do, but can no longer connect a 5D Mk IV via USB connection. Software environment is a fresh install of Win10 Pro x64, v1809.


  • If EOS3 utility open and running before connecting camera, the main window flickers briefly before red text 'Connection lost' appears and the main window becomes unresponsive. The camera screen continues to show the 'Connected to PC' icon.
  • If the EOS3 utility is not open before connecting camera, upon connection the black EOS3 splash screen appears, but the application then hangs - a spinning cursor appears before eventually Windows detects that the app has crashed and it greys out about three minutes later.
  • When connected via USB and accessed via Windows Explorer, the camera is recognised by Windows and the directory structure of the CF card can be browsed, but Explorer immediately crashes and closes the window if the DCIM folder is opened.
  • EOS3 running on the same machine can connect to and download files from the camera via wifi connection flawlessly, with no bugs or other undesired behaviour. The problems occur purely when connected via USB.

Attempted troubleshooting steps:

  • Disable wifi on camera - no change
  • All USB ports - no change
  • All other USB devices disconnected (except mouse and KB) - no change
  • Uninstall and reinstall of EOS utilities from latest online version
  • Uninstall and reinstall of EOS utilities provided on-disc with camera
  • Verify that USB connection possible to older Intel-based machine using same cable - performs as expected
  • Uninstall all Windows driver entries for camera - Windows detects new device on next USB connection and reinstalls - no change

This problem appears localised to the new Ryzen-based production environment, as the EOS3 utility and camera are able to sucessfully connect via USB on the older Haswell-E Intel machine and, as a test, on a new-out-of-box Surface Pro 4.

Any further suggestions or troubleshooting steps to attempt would be greatly appreciated, as we shoot purely in large-format RAW and so the file transfer times via wifi are cripplingly slow and seriously frustrating.


Firmware update 1.3.3 solved the USB 3 problem with AMD Ryzen processor. Today I upgraded my camera and connecting to USB 3 works flawless

View solution in original post


Thanks! Yes that did it. I had the firmware installed in July but didn't read the updates though they mention the USB3 problem as a first, and didn't have much time checking it because I was travelling. I just did a check and it works fine now, both eos utility and importing with Lightroom. I coincidentally installed F34 BIOS as well yesterday, but it will obviously be the firmware update. So the problem was with Canon after all, not AMD... And though I'm glad it has been cleared out and I can now download straight from the camera, I don't really need it that much anymore now that covid pandemic is gone here and I don't need to work from home anymore. I wish I didn't had to spend money on an extra webcam, USB hub, card reader, etc. That's more than a 100$ on things that should've worked just like that and which now basically can go to the trash 😞

Glad Canon finally fixed it after a year + of pure silence.  Very poor communication by Canon; they never even acknowledged the defective firmware with regard to AMD chipsets.

@peterVC wrote:
I just updated the bios of my Aorus x570 ultra to F33i which should be dealing with known USB issues, but the problem remains exactly the same as before. Really frustrating that a 4K camera and a 3K PC are simply unable to even transfer an image to one another. Was that a 1000$ extra option for each of the devices?

The firmware update didn't fix it probably because the AMD chipset seems to have a hardware related issue when it comes to their USB ports.  This has been an ongoing problem for a number of years.  It should not take years to update firmware to fix any type of firmware related issue, and it doesn't.

"The right mouse button is your friend."


Thanks all for your contributions - confirming 1.3.3 has also solved this problem for us.


Extremely annoying that it's taken the best part of three years for this to be resolved, with still no actual communication from Canon, but glad we're at the end of the road. 


Firmware 1.3.3 does not solve this issue.  I have an ASUS Zenith Extreme Alpha X399 board with a Threadripper 2950x and my 5D Mark IV is running firmware 1.3.3 and I am still unable to use EOS Utility 3 when connected to a USB 3.1 port (the application just hangs on the splash screen, just like it's always done).  Connecting to a USB 2.0 port works fine.  This still needs to be resolved.

I agree.  The new firmware fixed it on my Ryzen Lenovo laptop, but on my desktop PC (despite all the latest drivers and mobo firmware) I have the same USB3 issues connecting the Canon MKIV to any USB3 or 3.1 ports.  Frustrating that the Canon 5d mkIV works perfectly on USB3 with my 10 yearold intel-powered desktop.  While there is a fix that has helped many, there appears to be gaps in the solution.

The off the shelf AMD machines seem to work with the firmware update.  It seems like  the issue seems to occur most often with home brewed AMD platforms.

"The right mouse button is your friend."


Mine is a NZXT pre-built.