Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility not working with Windows 10


Hi all, 

  I just upgraded to Windows 10, and immediatly ran into the problem that is described in this thread about Windows 8:


After reading that thread I decided to unplug the other USB devices I had in the computer at the time (Garmin Watch, USB key, smart phone) and turn off the camera.  I then turned on the camera and ran the EOS utility and it found my camera and worked correctly.


Clearly this problem is still not resolved, but that simple work-around gets me downloading my pictures again.  There are a lot of other things people tried in the above thread, but I just unplugged the USB devices and was good to go.


OK, solved it. Went to the Canon Support site and although there is no updated software for WIN 10, I checked what was available in the Win 8.1 software. There is an "EOS Utility Updater"... this installed "EOS Utility 2" and now it is working just fine.

View solution in original post

197 REPLIES 197

Win 10 is far more troublesome for most people than prior editions of Windows and even when it is working it is far from a svelte system.  I use the pro version and my daughter has the same and we are both using identical HP Z-820 dual processor work stations.  The frequent windows updates will often add glitches to a formerly properly working setup.  Twice in the past 18 months I have had to go through the manual networking setup after an automatic update created issues with EOS utility recognizing my 1DX and 1DX 2 bodies connected via the gigabit ethernet ports in the workstation.


I was in the computer industry for several years after getting my undergrad and did a lot of consulting work with MS during the dot com boom era.  I have used just about every version of Windows going back to the days when Windows simply sat on top of PC DOS and even the much maligned 8.1 never created the amount of issues that Win 10 creates.  If you have nothing better to do for the next 12 months, google something simple like Win 10 high disc usage at startup and you will find enough reported problems with an equally wide array of solutions that only work in some cases leaving users to experiment and hopefully stumble across the one that works for their particular case without spending days and ultimately giving up.  


I only run the pro version which is less objectionable than the home versions because it gives you a little more control over what the OS can do without your permission but that level of control has dropped over the life of Win 10.  I MUCH prefer Red Hat Linux which came factory installed as the second OS on both of the household workstations but some programs I use, like DPP, aren't available for Linux yet.  After being very happy using Microsoft software for years (XP was the high point for stability and never created an issue with the many high end and home machines I used it with) I will be happy to say goodbye to the frustrating and time wasting mess known as Win 10.  It isn't so much that it is a new operating system but instead it represents a change in philosophy from MS that WE know what you need regardless of what you want as a customer and one of the prime examples of this is when someone in mid-presentation is interrupted by Windows going into update mode and grabbing the lion's share of system resources bringing normal operation to a grid lock.


Canon, PLEASE port your software and utilities over to Linux.  It is what MS is moving to with its various cloud services and hopefully MS will soon embrace this at the pro-sumer desktop level soon and get away from an incredibly poorly designed and supported OS.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

 Is your Win 10 an upgrade from Win 8.1 or Win 7? If it is, try a fresh install of windows 10. That fixed issues I was having. I think the upgrade process isn't 100% succsessfull sometimes.

@HighSierra wrote:

 Is your Win 10 an upgrade from Win 8.1 or Win 7? If it is, try a fresh install of windows 10. That fixed issues I was having. I think the upgrade process isn't 100% succsessfull sometimes.

It was an upgrade.


It is not worth all the work involved in doing that, easier to just take the memory card out of the camera and download direct from that.



Hopefully that is the only problem with your upgrade. I had several other issues as well.

@HighSierra wrote:

Hopefully that is the only problem with your upgrade. I had several other issues as well.

Not had any other problems.


I could spend an hour or so on it and find EOS Utility 2 still did not work. 

@Lundavra wrote:

@HighSierra wrote:

 Is your Win 10 an upgrade from Win 8.1 or Win 7? If it is, try a fresh install of windows 10. That fixed issues I was having. I think the upgrade process isn't 100% succsessfull sometimes.

It was an upgrade.


It is not worth all the work involved in doing that, easier to just take the memory card out of the camera and download direct from that.



The upgrade process has a habit of sterilizing your device drivers, and purging anything it [arbitrarily] deems incompatible.

"The right mouse button is your friend."

Good afternoon from the UK.

I have stumbled on this forum after many weeks of searching for a solutin to the EOS utility problem not working in windows 10. It seems that there are many people who have this problem, and a whole raft of possible solutions. SO:-


Original EOS utility from the solutions disk working fine under Win7 with my EOS 5D MkIII.

I can't remember why I had to update the EOS Utility software, but it would not do an auto update and I had to download euw3.4.30 installer from canons website. Problems straight away I got an error message and it would not auto-run when the camera was connected. Contacted Canon for help. This was 31/12/15. So now you know this is not a new problem. Eventually got it working after many software deletes and installs, and using CCcleaner to remove all old bits from the registry. The problem apperared to be a conflict with old software left on the system and causing a conflict, despite Canon insisting that it was not a problem, however it all worked.......... Until the Windows 10 upgrade.

I did the win 10 upgrade and it was fine, except Loads of other applications, particularly Lightroom and TurboCad went pear=shaped and would not function correctly.

Backed files up and did a clean install of windows 10. Re-installed all my software and evrything was working fine, (and much quicker post upgrade) except the EOS utility. This was installed from the original downloaded Canon update. and again would not recognise the cameras.

Canons solution was to uninstall and re-install the software. No Joy.

I then uninstalled the EOS utility update ( EOS utility 2 and 3) For info they are both installed as per a previous post, and installed the original EOS utility from the solutions disk. That worked fine.

Re-installed the EOS Utility update and NO WORK!!!!  This was getting frustrating. Back on to Canon UK. that was on the 18th June. After a whole series of emails and no solution I found this forum.

Whilst there was not a particular solution here some peoples experiences set me pointing in the right direction. and this is how I fond the solution to my problem. The steps in diagnosing the problem may help others.


It had not occured to canon to ask about users. My system is set up with an administrator accout which is used for software instalation and maintenance, as per Microsofts reccomendations many years ago.

The update was installed using the administrator account.

More emails to Canon, More uninstalls and re-installs.

I now had 4 instances of the canon camera in my AutoPlay list in settings and it is impossible in win10 to select an aplication on an event. It is also dam near impossible to get rid of the multiple copies of a device. This requires going into the registry and manually deleting them. I had a real difficulty in finding them.

Once ALL the refrences to the EOS utility and the cameras was uninstalled and the registry cleaned I tried installing the Updated EOS utility from the user profile. This was blocked. I Tried changing my user account to an administrator account and installed the EOS utility. This worked fine until I re-set the user accont from administrator to standard user. However it all worked in the administrator account.


Here is the clue to diagnosis.

In your administrator profile start your task manager and look under background processes. You should see EOS utility (32 bit) in the list. This it the program that monitors the USB port for the arival of a camera. Check to see if it is running in your user profile. In my case it was not.

Running the EOS utility in the user profile got evrything working, but the utility then resides in the Apps section. A bit of research on how to get an app to run as a background process and I found it was a simple matter of clicking on the start up tab in the task manager and enabling the EOS utility, this was listed, but shown as disabled. Enable it. Re-start your computer and check.

Hopefully all will be fine with the EOS utility (update) working in the Administrator profile and  the user profile as well.


I have no idea why, after a bunnch of emails and several weeks worth of replies from Canon the question of user profiles was not asked. I have no idea if it was necessary to clear out all the old refrences in the registry however it did get rid of multiple occurances of the same devices.


Sorry to be so long winded but the specifics may help someone else.


Good information there...Thanks for the detailed reply. 

I had also faced issues with this untility, I downloaded the latest software from internet and somehow could connect all the dots and make it work. 

I had this same problem after upgrading to Windows 10.  When I plug the camera in and switch it on, I no longer get the message from Windows asking me what I want to do with the camera, but also the Canon EOS Utility no longer starts automatically.  When I ran it manually I got the window asking me to pair with the camera over wifi or LAN, bt no recognition that it was plugged in.

I downloaded the updater for the EOS Utility from the Canon site and installed it.

The installer changed the icon on my desktop, so I assumed it had installed it properly.  However, when I ran it, I still got the same problem, with the request to pair over wifi or LAN.

When I looked in the Windows menu, I discovered that the old utility was still there and the new utiltiy, labelled EOS Utility 2.  When I ran the new utility, it worked.  I have now changed the desktop icon to point at the new utility's .exe file, though, when I did that, it changed the icon back to the old one!

If this is an updater, it should replace the old version with the new version.  The Precaution section on the download page says it will only work if there is an existing version.  This is messy. 

Updater 2.14.?? dated October of 2015 worked for me with W10. And I did not have to uninstall the EOS 3 software. It merely overwrote it. First connect with 5DMII allowed me to choose to select the images I wanted to download. Works great. Here's the link, just type in your model and click on Get Drivers & Downlaods, then select Updater 2's latest date:!ut/p/z1/04_Sj9CPykssy0xPLMnMz0vMAfIjo8zif...


Thanks so much to whoever it was who found and suggested this, I cant see the entire thread from this reply or I'd thank him by using his/her name.


I should say that the first Utility that auto updated was the Wi-Fi version, not useful to me, then I uninstalled and resinstalled the utility, which must have been the EOS 3 utility, still didn't work. Finally through this very helpful community I am able to dowlaod pictures again. Thanks to Canon and the members here.

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.