cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Photos importing on iOS Canon Connect app with wrong date

jack_clarke
Contributor

Hi there. I’m using a Canon EOS M6 Mark II with the Canon Connect iOS app. Whenever I try and import photos onto my iPhone using the app, the photos import with the date set as the time the photos were imported, not when they were actually taken.

 

I’ve checked the date on the camera and everything is correct - it just seems to be an issue with the import. Has anyone else experienced this or know a way to easily fix it (without manually changing the date/time for each picture)?

Thanks in advance!

11 REPLIES 11

Waddizzle
Legend
Legend

Are you looking at actual EXIF data, which is metadata that is stored inside of the file.  EXIF contains all of the exposure info and camera settings?

--------------------------------------------------------
"The right mouse button is your friend."

Yep, I’ve checked the actual EXIF data and that’s getting overwritten by the import date. All of the rest of the data (exposure, shutter speed etc) is there as it should be

The problem here is that it does not sort the photos in the right order. I have photos taken from my iPhone and photos imported later on in the day through camera connect. All the imported photos have their date taken overwritten with the date when they were imported instead of the original date. All the rest of exif data is there. 
Is there anyone from Canon who can pick this up and fix it please?

 Thanks

jack_clarke
Contributor

Sorry to bring up an old topic again but this is still bugging me.

For the last 6 months, I've been having to carry my MacBook everywhere to import images with the right date (which feels annoying when I have an iPhone and iPad which should be able to do the same thing, whether that be wirelessly via the Camera Connect app, or via USB-C from the camera into the iPad).

I have played with every setting on the Camera Connect app and images still get added to Photos with the import date and not the image taken date/time. The same happens if I import via USB-C on my iPad straight into the Photos app. All other exif data (including location, shutter speed, f stop etc are all there as they should be).

The weirdest thing is that if I import a video taken on the camera via the Camera Connect app, it imports with the correct date taken and not the import date, so it just seems to be an issue with images.

Has anyone else experienced something like this? Or does anyone else use the Camera Connect app and manage to import image with the correct date? At least that way I could figure out if it is a bug in the app/iOS or if it is my set up! Thanks in advance 😀

Two questions.  

What app are you using to read the EXIF data on your mobile devices and your Mac?

Are you importing the JPEG or RAW files to your mobile devices?  

--------------------------------------------------------
"The right mouse button is your friend."

Hey - thanks for the response!

Reading the data on the Photos app on both iOS and MacOS. Any images imported via Camera Connect have the EXIF original date/time as the time I imported it from the app, rather than the date captured/taken. Any photos imported directly into Photos (MacOS) via USB-C have the EXIF original date/time as the date captured/taken, so no issue. I've checked all of these scenarios on MetaImage as a second opinion.

I don't really have any need for RAW files, so I shoot in JPEG and import in JPEG. Hope this helps!

I always shoot RAW and import to a Windows PC using USB.

When you import your JPEGs from the camera are the images still the same size when they are saved on your mobile devices?  W x H?  By default, I think JPEGs get resized downward to save space on iPhones.

--------------------------------------------------------
"The right mouse button is your friend."

Ahhh I see - yep, images come across at original size, full resolution etc. Just seems to be the date that gets overwritten by the import feature on the app

shadowsports
Legend
Legend

Greetings,

This thread is a year old with no activity since Sept of last year.

I believe its safe to say that the version of iOS or Android, and the version of Canon Connect are different today than when this thread was created.  

If you are looking for assistance, please start a new thread.  It should include the type/model of your mobile device, the version of its OS and the version of the Canon Connect App you are using?

I am using a Pixel 6, running Android 13.  My Canon Connect App is 3.0.11.25_1341.  My imported photos are being imported into their own album with the correct dates (when the photos were taken).

If I copy these files from my mobile device to another computer or storage device, the date will change to the date and time the file was moved or created.  This is a function of windows or MAC, and is expected.  It has always worked this way.  The file creation date and image capture date are 2 different things.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements