Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility Shuts Off on Own During Live-View Usage


So I have a Rebel t2i connected to my PC (Windows 10) with the USB port, and it automatically starts the EOS Utility software when I connect it, but after 30 minutes (I have multiple videos that show it's 30 minutes) the software will automatically shut off.


• I'm using the Live-View, not recording though. I keep the live-view open and do a window capture in OBS so that I can have a quality camera as a webcam for streams. (I'm fully aware that this camera is old, but it's better quality than a $60 webcam).

• The camera is on AC power, and the camera itself doesn't shut off when the application closes.

• All I have to do is press a button on the camera and the application starts again - I don't have to replug anything. 

• I'm not recording during because I get lag when I do this, and I don't want that.


• I've looked into the settings, and can't find anything that would cause it or make sure it does not happen.

• I've tried "automatic shut off (except with AC power)" on and off and it doesn't change anything.

• The version I'm using is up to date.

• Tried with and without SD card, doesn't change anything.

• Changed cables and it doesn't change anything.

• I've tried pressing buttons in the app preiodically to let the app know it's being used, and it hasn't worked.


I don't know why an app would close out every 30 minutes on it's own, I haven't had that issue with anything else. 

Let me know if there's any more info that could help, or any other (cheap) way for me to connect my t2i to OBS/Streaming Software that won't shut off every 30 minutes.


If you use the "green mode" on the camera, does that prevent you from changing settings (e.g. aperture)? 

Hello i just got into this camera thing but for streaming using OBs i have a Rebel T2i the settings for auto shut off are alredy enabled to "off" and after 30 minutes still disconnects from the webcam utility software even using the HDMI output still does the same is there another way to get around it?

Auto off needs to be set to 1 minute

ohh ok i'm trying it now so far it didn't shut off thanks for the tip 🙂