cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility Compatibility with EOS 7D and EOS 20D

A_Random_Dude
Enthusiast

Hi there:

I've installed EOS Utility, and had no issues whatsoever bringing in photos from my 1DX Mark III into the folder I specified.

My question is, if I connect my 7D and 20D (having bought them used, I don't have the necessary cables yet; those should be here this week), will EOS Utility work with those cameras as well? Or are there specific versions of Utility for specific cameras?

Thanks in advance!

300D, 20D, 7D Mk II, 1DX Mk III, a few decent lenses, and plenty of questions
1 ACCEPTED SOLUTION

You won’t find V2 on the site. But 3.13.3 should install V3 and V2. Did you look in the folder Canon Utilities->EOS Utility? Should be a folder for EOSU3 and EOSU2. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

View solution in original post

23 REPLIES 23

A_Random_Dude
Enthusiast

Well, there you go. No wonder you're a legend! It's reading my 7D right now, and I'll check the 20D later.

Thank you so much! 👍👍👍

300D, 20D, 7D Mk II, 1DX Mk III, a few decent lenses, and plenty of questions

A_Random_Dude
Enthusiast

Well, 2 out of 3 ain't bad. The 20D doesn't seem to show up no matter what. But, it's better than it was, so that will do.

300D, 20D, 7D Mk II, 1DX Mk III, a few decent lenses, and plenty of questions

Early cameras used software called EOS File Viewer. Even if you could find it it wouldn’t run on current macOS since it was 32 bit software. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Vivek1
Apprentice

I ran into similar issue, after Windows periodic update EOS Utility ver 2 wouldn't connect to my T4i. Uninstalling and reinstalling latest SW didn't help. It seems like the EOS Utility 3 is hijacking the USB connection.  
I was able to resolve this issue by uninstalling EOS Utility and related SW. Then downloaded the "EOS Digital Solution Disk Software 29.1A for Windows (For users who cannot use the bundled CD)"  from the SW site. I selected my OS as Windows 7, and downloaded the original CD which has the EOS Utility 2.0 shipped with the Camera. This fixed my issue. I will wait for some time to see newer EOS Utility which has 3 and 2 gets and update. Location of the original CD with EOS Utility is at : 
https://pdisp01.c-wss.com/gdl/WWUFORedirectSerialTarget.do?id=NGE4MWUwOTJk&cmp=ABR&lang=EN

 

Announcements