Showing results for 
Show  only  | Search instead for 
Did you mean: 

Digital Photo Professional 4 Non-responsive Following File Save


I've been using DPP4 since its introduction on my Windows 7 desktop without incident. I just upgraded to a new computer with Windows 10, more RAM (16 GB), and faster CPU (i7-8700). I now find that DPP (4.7) hangs for about 30 seconds following a file save.The strange thing is that DPP (and only DPP) becomes temporarily non-responsive following ANY file save, even a small Notepad text file. Watching Windows Task Manager, I see that the CPU utilization jumps to about 12% following a file save for about 30 seconds, but only when DPP is open. Any idea what's causing this and how to fix it?



Hi Jazzone,

Welcome to the Canon forum! So that the Community can help you better, we will need to know what model product you are using.  
Any other details you'd like to give will only help the Community better understand your issue.

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email. 

Not sure what you mean by "model product". I've defined the software (DPP 4.7) and my computer hardware (Dell XPS 8930 desktop) and software. Not that I believe it matters, but I use a number of Canon cameras including a 7D Mark II and PowerShot S100. Let me know what else you need to know.

I have 1DX mark ll, so I have to update my DPP to the newest, but the problem is same as most of the people, when I save the files, then the DPP has been freeze. I have a clean Windows and buy a new computer but the problem is the same. 

my computer: i9700/ 32G DDR4/ Samsung EVO980 Pro SSD on Raid/ Toshiba 4T Sata hard Disk X4/


I talk to the canon service center on HK, on JA, on TW, on CHT. from V4.10 to newest, but it has been nothing to change. Do we need to change the camera company or not?


I am using the current version of DPP with a 1DX and 1DX 2 and it is working well with no freeze on file conversion/saving.  The only time it is annoyingly slow is when applying digital lens optimizer with a file that was shot at high ISO and is undergoing significant noise reduction and at times it will take up to 25 seconds to complete processing to display the image HOWEVER file conversion/save is still fast under these conditions.


You should have plenty of processing power and memory with that setup and I suspect it is a Windows 10 issue related to a driver for one of your devices.  I lost count long ago of how much time I have spent dealing with Windows 10 issues on several different high end machines, unlike its predecessors it is far less robust over a wide range of hardware.  Most of my use of DPP is on a HP Z-820 with twin Xeon processors and 256 GB of memory (128 gigs per CPU) but I also use it occasionally with a HP Zbook that uses a 4 core processor and 32 gb of memory with no freezing issues.  Some of the earlier versions of DPP did have a memory leak problem that slowed them down even though they only used a small percentage of system memory but I haven't run into that with the current version and after some all day sports shooting I have worked on directories with over 1,000 files from the 1DX and 1DX 2 for several hours with no slowdown issues.


I did have to jump through multiple hoops with both PCs during recent major updates to Win 10.


If you haven't already done so, completely uninstall DPP using the Windows control center and then install it again.  Take a look using task manager when it is freezing during save to see what is going on with CPU and storage loading, you may have a virus or malware program interacting with DPP.  The malware protection that comes with Win 10 is a major resource hog.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

I think that was when we are up to win10 and work for a raid system then DPP should be freezing. I have 4 computer system, Win10 are all of them, but it is not on Raid being only one, that one would be no problem of any problems of DPP3 to DPP4. Which the new system is running with m.2 Nvme Raid and another computer system was E3 Xeon and just upgrade to PCI-E SSD Raid, before it has the basic a hard drive system with two years ago then all of the problems are coming for DPP.

So that I think DPP has not to support any kind of new hard driver, and I also talk with Microsoft engineers and they are proving the Canon Dpp4 is not support the Win10 system.



Just a guess, but maybe DPP is scanning the file tree each time to keep it up to date?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

It seems strange that it would do that even when saving an unrelated file, such as the Notepad file I mentioned in my original post. Launching DPP is faster than the file save delay (15 vs. 30 seconds) and that's when you'd expect it to scan the file tree. Furthermore, I didn't see this excessive delay in my older Windows 7 desktop.

I have exactly the same issue with DDP on my Windows 10 computer. Not only saving file but also deleting any file on my computer will cause DDP stop responding.

Icechamber, YES, I just tried a file deletion with DPP open and DPP hung the same way as with file saves. This has to be a bug in DPP. I wish there was someone at Canon with DPP knowledge we could speak to about this.