Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP4 version 4.9.20 Hangs Frequently Becomes Unusable


I updated to DPP version 4.9.20 on a Windows 10 PC with 32 GB Ram and found that after several minutes of use DPP would pause or hang for a couple of seconds and the Windows spinning circle warning would display. This pausing would happen repeatedly every couple of seconds making DPP almost unusable. The Windows Resource Monitor showed that the amount of memory under Working Set increases from around 977,000 KB to around1,500,000 KB for DPP4 as DPP goes from no problem to repeated pausing. I uninstalled DPP 4.9.20, rebooted and reinstalled the old version DPP4, 4.6.30 but still had the same problem with the constant pausing and increasing use of memory even though this version worked without a problem on this computer. Canon's technical support had not heard of the problem and was of no help. Has anyone else expericenced this problem and come up with a solution?


I think I have really solved the problem with Canon Digital Photo Professional 4 giving the spinning wheel wait symbol and pausing constantly. I did a drive cleanup on the C: drive and on the drive I have my RAW files on to get rid of all temporary files, etc. I was thinking maybe when I installed the updated DPP 4 that it may not have cleaned up all of its temporary files, or a temporary file got corrupted etc. So tonight I have been able to work with DPP for 4 hours without any spinning wheel wait symbols and pauses. 

View solution in original post


“On my computer DPP was almost unusable, but this has changed after moving all my photos from the main drive to an external (previously empty) HDD.”

That is one way to change the startup folder to an empty folder.
"The right mouse button is your friend."

Why NVidia? Because it builds previews. DPP also adopts some default multimedia behaviors from Windows, which means it adopts some settings from Windows Media Player; ie; startup folder.
"The right mouse button is your friend."

It does seem strange. I tried to update the Nvidia Driver (it was due time anyway), put it did not help in any way. The problem persists (i have tried change all the Media player and DPP startup folders, but it doesn't make any difference). 

I know this thing is file related, but changing startup folders has no effect on my system, so there has got to be something more to it.  


At least now i know that i can open the Task manager, "end" Nvidia container process, but not stop the "Nvidia DIsplay Container LS" Service. As long as i boot that process, i will have peace for the remainder of my session with DPP. 

Depending upon your card, it may have also installed Geforce experience from Nvidia as part of the standard install.  Unless you are using the machine for gaming, get rid of this because it has caused a lot of Windows 10 issues.  I installed a Nvidia RTX 2060 recently and had to remove a bunch of extra stuff that auto install with the current driver download.


I have a couple of instances of NVIDIA container running, one with Display Container LS nested within that takes care of running the NVIDIA configuration program.  If you let Geforce experience live, it will launch a lot of other stuff that you probably don't want.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video


I've found that the wheel goes away within 1 second of opening Tools / Preferences (for speed, using either of these):

  • Alt+T, P
  • Ctrl+K
click here to view the gallery