cancel
Showing results for 
Search instead for 
Did you mean: 

DPP 4 with 24-105 RF lens

newaim
Apprentice

I am a brand new Canon user trying to figure out how to post process my images taken with my new EOS R with a 24-105 RF lens. When I import the images to DPP 4 (which I just downloaded) the show up small with a ? in the corner when I go to edit image. When I mouse over the image I get this message "Captured with a lens not compatible with this version" I have downloaded the lens data to the default directory, but still have the problem. I have processed images taken with a Tamron 150-600 lens (with an adapter) and the lens data works fine. How can I resolve this problem. Any help would be greatly appreciated.

1 ACCEPTED SOLUTION

newaim
Apprentice

I found the problem. It turns out that the DPP 4 that I downloaded yesterday was not the newest version. I installed the new version and now it works.

View solution in original post

2 REPLIES 2

newaim
Apprentice

I found the problem. It turns out that the DPP 4 that I downloaded yesterday was not the newest version. I installed the new version and now it works.

shadowsports
Elite

Greetings,

Canon / DPP (any version) only supports lens registration/data of Canon products.  You can process pictures taken with other lenses, but DDP does not support 3rd party lens data.

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order
Announcements