Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera Connect failed to save images



Camera Connect App Version: (build 967)

IOS version: 12.1


The phone is able to connect to camera, and images on camera can be displayed. 

However it failed to save images to phone.


I tried the followings but not work. 

- Delete and reinstall the app

- Reset wi-di setting on camera


Anyone can advise?







Were you ever able to resolve the issue? I have the same problem.

The only thing that helped for me was to factory reset the iPhone and manually set it up again. When I tried to do the automatic restore process from backup, I was experiencing the same issue again. I figured it was some setting like the storage access that I declined while setting it up for the first time. And it doesn't get reset by just erasing the app. So factory reset and manual restore was the only solution for me.


Has anyone been able to resolve this issue?? Very frustrating! I have been using the EOS remote app for a couple of years and have never had an issue with it until yesterday. When I click on an image to save it, it says Failed to save image.

I have tried everything...shut everything down. Deleted app reinstalled app. WiFi connections... I have no clue!

can someone please let me know if you have had this same problem and have resolved the issue?

I just started the same issue today exactly as you described and I tried all those things also. It is VERY frustrating! I have an Android phone and there wasn’t a recent update. A few days ago I was able to save images and now it simply won’t. Can anyone help?!!

Same problem and Canon is no help

It had something to do with iOS 12.00.xx prior to iOS 12.3.1 on my iphone 8s+..  My old iphone 6s+ with IOS 11.xx.xx did not do that. All I did was update the iOS of 8s+.  You may need to update your camera firmware and the Canon app.

YES! I updated my iPhone XS to IOS 13.1 and all of a sudden the older EOS Remote was able to save photos to my phone. I have not tried the newer Cannon Connect to see if it works.
click here to view the press release