Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera Connect failed to save images



Camera Connect App Version: (build 967)

IOS version: 12.1


The phone is able to connect to camera, and images on camera can be displayed. 

However it failed to save images to phone.


I tried the followings but not work. 

- Delete and reinstall the app

- Reset wi-di setting on camera


Anyone can advise?








Hello All,


New member here!


I got the same issue when I try to transfer an images from my EOS R to my iPhone 8+. I've tried it both ways...transfer it from the camera and  download it via the CameraConnect app.  both would give me an error  saying "Failed to save image".  App has Read & Write permission.  My iphone has 40G free space.  Any Idea what else could it be?


Tech support told me to disconnect the bluetooth connection and try to transfer again with the built -in WIFI and It did not help.  he said it got to be something with the phone setting which I agreed...but what is it?


Could it be IOS recent update?




Thanks Bokehen. the recent iOS update was related to the patents involve adjusting the size and appearance of photographs. I'll let the Apple support know.

Hello boneo, 


Thank you for letting us know of this issue and we are sorry you experience issues connecting.  We recommend disconnecting the camera, un-installing the software from your phone and then re-connecting the camera again.    

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

thanks Tim
I did what you suggested and it did not help. it is not a big deal. I can always take the memory card out and transfer them with my tablet.  It just a little inconveince.




Hello, I need help with this too. All of a sudden the Camera Connect app will not save images. I was able to do this just a few days ago, but now nothing will fix it. I have deleted and reloaded the app. I have enabled all of its permission in advanced settings. I have an Android phone and there was no recent update. I need this feature to work because I specifically chose a WiFi enabled camera to be able to quickly connect to my phone. I have not seen a reasonable answer to this problem yet.

thank you!


Did anybody find a solution for this issue? I have the same problem on my iPhone 8 on ios 12.2 with the latest canon camera connect.


Good news, They finally got it fixed.  I was able to do that with iOS 12.3.1 yesterday.. 

What was the solution?

Still an issue for me too!

It states ‘image failed to save’. Please help! I’ve deleted the app and reinstalled all the WiFi details on the camera.

Any help would be much appreciated!
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th