Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Vixia HF 800 "Cannot record" error


I bought brand new Canon Vixia HF 800


I record 1 or 2 clips successfully , and at the 3rd clip "Cannot record" error popus up at camera screen .


I use sandisk Ultra 64 GB Micro SD


I initialized the SD card from camera "other settings"


But still get the error at clip 2 or 3  ?


So right now I record one clip only , transfere it to computer and then repeat . Very annoying I cant record more than 2 clips without this error ?





I changed SD disk to 16 GB Transcend and problem solved..thx 


I have a similar problem.

SD card was used in a Sony camera.  I used the card and got the 'card is full' message.  Later I moved the files to my mac.

When returning the card to the Vixia, I get the message immediately, but there's nothing on the card but some folders and system files I don't know much about.  There should be 64 GB free, but it shows only a few KB free.  

I figure I should reformat the card, but I can't find a format option on the camera.

Any ideas???



Hi BobbyZ,


Thanks for posting.


In camcorders, the format command is sometimes replaced with the "initialize" command. For a step-by-step guide for this, please click here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.