Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎08-19-2015

mg2950 not working on WiFi

Please someone help with this:

 

I have an MG2950. I tried unsuccessfully to connect via the mobile ios app and my Mac laptop. On the phone I joined the canon setup network, which let me find my home wifi network, put the password in, and I got the message that said "signal sent." But from there my phone still couldn't find the printer on my home wifi network.

 

Today I went back to the store (which is annoying to have to do) and bought a usb cable. I hooked the usb up to the computer and installed the printer. I was able to install and register it. It works with the USB. But I need the wireless function or else the printer is almost useless. How do I set the printer up on my wireless network? I've tried everything I can think of and everything I could find online and on youtube. This is very frustrating. 

 

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement