Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

199 REPLIES 199

One of the duties of the FCC is to prevent transmitting devices interfering with other transmitting devices. Most WIFI networks run at 2.4 Ghz. The ST-E3-RT runs at 2.405-2.475 Ghz. I'm not an RF expert but with transmitting frequencies so close together logic dictates a possibility of interference. We may have proven it to ourselves that interference is the problem but convincing anybody else, including Canon is pretty much impossible. Infrared works but I paid for a transmitter that I would like to use. Wish everyone the best of luck.  


I have had the same problem using a 600EXII-RT and ST-E3-RT.  No luck with any of the suggestions on this posting-  evenchanging the ID and channel to something really off the wall did not help.  Only thing I have not tried is using the RT set-up outdoors away from WIFI whic hseems to be the general consensus as the root of the problem.  Guess I'll have to settle for resetting the system every few minutes.  At least I only have one flash in use and I'm not a pro,so I guess I'll have to live with this for now.


2 questions:

theres a version 2 of the st-e3-rt transmitter released. When was it released and dies it correct this issue?

2) the also new canon st-e10 remote, does it have a wider bandwidth to support new. Communication around wifi?

why is canon silent on this?

I bought a V2 because I "thought" the old transmitter was the problem. V2 has same connection failures. Canon is ignoring the situation. Fixing it would be pretty difficult. Too many WiFi networks in the world. 





Curious if the v2 transmitter & the NEW el-1 speedlight are a more robust pair.

No, the new version 2 transmitter has the same issue. I suspect that this is why Canon refuses to acknowledge that there is a problem. They are well aware of it and would have to recall ALL of their flash triggers in order to fix it

Can anyone say “class action law suit”


I set up a test using my four 430EX III-RT speedlites and ST-E3-RT (Ver 1) where I place each flash in a different room in my house. Timing for 30 minutes segments, I would see if any links were lost then rotate the flashes (to make sure I didn't have a defective unit). Using channels AUTO, 6 and even 10 resulted in one or two failures every time despite using the RT scan feature, which showed those (numbered) channels as strong.

After looking for other examples of losing link with other 2.4 GHZ radio systems (Godox, etc.), it seems the issue came down to either sporadic voltages with rechargeable batteries, RF interference in the ever crowded 2.4 GHZ band, or both. One suggestion was to install "WiFi Analyzer" (for Android phones) to see traffic. I did so and sure enough, the channels I'd been using had a good deal of traffic on them. Channels above 13 were clear. So I switched to channel 15 (despite the RT scan showing channel 15 as weak) and suffered just ONE failure in two hours of rotational testing!

In conclusion, I'm feeling pretty confident I'm losing link due to RF interference (which is due to Part 15 of the FCC Rules – “(2) this device must accept any interference received, including interference that may cause undesired operation.”). I'm not sure about the rechargeable battery voltages -- it may contribute. I plan on swapping in alkaline batteries and repeating the test.

Of course, my BIG issue is why isn't the unit re-linking after it's lost? If I purposely lose link -- with distance or obstacles -- and resolve the issue, the speedlite re-links. But for some reason, with interference (or rechargeable battery issues), once the link is lost, it's lost for good. Some claim you have to power cycle everything to get the link back. But I found just toggling radio off then on again with the affected unit results in a re-link.

I sold off a BUNCH of Yonguo YN622C transceivers to go pure Canon.  You'd think, with what they charge, it'd work flawlessly!  So far so good with channel 15. I guess I'll try Godox if this doesn't hold (which is no panacea as all systems seem to be affected to some degree).


And I thought I tried everything. Never thought of wifi analyzer. Thanks for that


As someone who was experiencing dropped links on a regular basis, I believe my issue has been resolved (at least to my satisfaction). As I’ve indicated in another post (above), I read forums of other 2.4 GHZ triggers (Godox, etc.) and came to the conclusion that RF interface in the channels was causing drops. So I used a Wi-Fi analyzer for Android phones (WiFiman is free, good and ad free) and saw interference where the RT scan didn’t. I set the channel manually and my drops almost disappeared – almost (from 1 to 2 every 30 minutes to 0 to 1 every two hours).

I now use channel 15.

But then I got to thinking about the ID because I was using a custom one (0333). In other systems that have IDs – so you can “uniqueify” your setup – you have at most 100 to chose from (0-99, typically). But Canon’s RT system has 10,000 – 0000 to 9999. That’s a lot of IDs! And each ID must have a unique radio frequency assigned to it. Speculating, I think that the gap between frequencies is tiny and, therefore, the fault tolerance low: RF interference is far more likely to affect these IDs than the channels. So I set my ID to 0000 and repeated the test and had zero drops in two hours. I ran the test again using 9999 and once again had zero drops in two hours. I believe using the extremes of the ID range bookends the fault to just one direction, up only (if using 0000) or down only (if using 9999). If this is true, this single change may reduce drops by 50%!

I now use ID 9999.

Since making these changes, testing for hours yesterday (and even today), I have not experienced a single drop. My 430s x 4 have gone to sleep (1 hour setting) and awakened successfully (using the ST-E3-RT (v1)), ran out of juice (FYI: I’m using rechargeables), or lost – and regained – link.

I’m happy.

As for Canon, there’s really not much they can do, except maybe reduce the number of IDs (why 10,000?). When they created the RT system (2012), there was a lot less interference and the FCC mandates that devices must accept any interference received, including interference that may cause undesired operation. And rest assured that the “others” have drops and misfires as well so changing to another 2.4 GHZ trigger system isn't really, “The Solution.”