Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

139 REPLIES 139

This solution makes a lot of sense, and good idea to have custom settings anyway.  Easy to be in location with another photographer near by.  I have tried custom channel (12) and custom ID somewhere in the middle of the range.  So far it seems to hold link a bit longer, but still times out about 5 minutes.  Half depressing shutter seems to bring it back some of the time.  If that doesn't work turning transmitter off and on has seemed to relink everything.  This is far easier solution that pulling down a light stand to reset the slaves.  So my tentative conclusion this may be a workable solution.

Update: well not so easy.  Sometimes it works sometimes not.  Still had to turn slaves off and on when it really goes dead.  Very frustrating.

So now I'm experimenting with going back to the future and using the optical link instead, which generally works inside it seems.  Sure wish Canon would chime in on this one.  They have to be aware of it.


Boy does this sound familiar. I did all of the above but not sure if I changed the radio ID. I'll have to try that. One thing I noticed when I had the flashes under an rf shielding blanket. My phone still showed my wifi but not any of the neighborhood. Flashes all worked as advertised. Outside the blanket I still had link issues. So, one of my neighbors has a "dirty" wifi network. Bottom line the problem is not wifi as as a whole, just some wifi. Good to know but doesn't really solve the problem.

     As a side issue, I got a request from Canon to review the community support page. I highlighted their "non response" to this issue. 


I tried changing the flash ID. Worked well in the living room where the seating is more comfortable for testing. Moved to the garage where I do most of my shooting ( water drops.) 3 flashes worked, 1 didn't. Changed the ID twice(3000) now all work as they should. Conclusion; what works in one space may not necessarily work in another. The RF environment is very variable. Distance from router, weather conditions and probably more that I am unaware of. Be flexible. If possible do a pre-check on location where you will be shooting. Even though I have things successfully setup now, tomorrow it may not. The environment changes. I hope this helps


I want to add another report to this chain, as I've experienced the same issue with multiple units including one new unit less than a year old.

Around the beginning of 2022 I started experiencing the same behavior that PhillyPhoto described in the thread parent. Link drops between the ST-E3-RT and one or more other 600EXII-RTs, or between one or more of any combination of the 600's.This occurs on channels that the scanner shows as maximally 'good' with various IDs, in any part of the apartment.

I've tried unplugging my wireless router to eliminate the strongest known source in the apartment, it's also the only wireless device that has been updated in my apartment around the time the problem began. Everything else has been unchanged. However, I live in a dense part of Manhattan. In 2021, I used the grouped flashes extensively in wireless mode with complete reliability.

I have to conclude that there's a new interference source, or new form of interference, that causes the RT radio to lock up. As you've all experienced, I expect, once the link light goes red, you must power-cycle every unit to bring them back up. It would have been nicer if the RT radio component accepted the interference and recovered on its own.

To validate that the issue wasn't in the flash units themselves, I placed them in the microwave oven and observed that they remained linked until one unit hit its auto-power-off limit. 

I don't see a lot of discussion about this problem on the general Internet, so I have to conclude that it's just beginning to become a problem with the RT system in some areas. 

If you've stumbled upon this thread from Google, and are experiencing the same technical problem, please chime in on this thread.

In the meantime, I'm using the classic infrared RT mode, which gets the job done, but when one pays such a premium for Canon hardware, one expects to have full functionality. Fortunately they left the infrared mode intact, else I'd have no workaround.


One of the duties of the FCC is to prevent transmitting devices interfering with other transmitting devices. Most WIFI networks run at 2.4 Ghz. The ST-E3-RT runs at 2.405-2.475 Ghz. I'm not an RF expert but with transmitting frequencies so close together logic dictates a possibility of interference. We may have proven it to ourselves that interference is the problem but convincing anybody else, including Canon is pretty much impossible. Infrared works but I paid for a transmitter that I would like to use. Wish everyone the best of luck.  


I have had the same problem using a 600EXII-RT and ST-E3-RT.  No luck with any of the suggestions on this posting-  evenchanging the ID and channel to something really off the wall did not help.  Only thing I have not tried is using the RT set-up outdoors away from WIFI whic hseems to be the general consensus as the root of the problem.  Guess I'll have to settle for resetting the system every few minutes.  At least I only have one flash in use and I'm not a pro,so I guess I'll have to live with this for now.


2 questions:

theres a version 2 of the st-e3-rt transmitter released. When was it released and dies it correct this issue?

2) the also new canon st-e10 remote, does it have a wider bandwidth to support new. Communication around wifi?

why is canon silent on this?

I bought a V2 because I "thought" the old transmitter was the problem. V2 has same connection failures. Canon is ignoring the situation. Fixing it would be pretty difficult. Too many WiFi networks in the world. 





Curious if the v2 transmitter & the NEW el-1 speedlight are a more robust pair.

No, the new version 2 transmitter has the same issue. I suspect that this is why Canon refuses to acknowledge that there is a problem. They are well aware of it and would have to recall ALL of their flash triggers in order to fix it

Canon LIVE! Canon LIVE!