Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

193 REPLIES 193

This sounds interesting, and may be why I've not experienced the issue with the dropped links like others in the forum. 

From day 1 of owning my first pair of 600EX-RT and an ST-E3-RT way back in 2012, I changed the ID from the default 0000. I once worked out that the most awkward - needs the most button presses - is to use 5555 as the ID. The reason was that I did some demonstration photo shoots on photo shows, and I wanted to reduce the chance that a person in the audience would be able to control my lights, knowingly or not. 

As all units leave the factory with the ID set to 0000, therefore by default any Speedlite or transmitter owned by anyone has a 1 in 16 chance (15 channels plus auto) of being on the same channel and ID as you, if you use ID 0000.

Add in that the earlier Speedlite 600EX-RT and ST-E3-RT units had a firmware update that needed them sent in to Canon as they were prone to dropped links and general instability when working with more than 6 or 7 devices. I ran some Speedlite workshops, and saw that issue in practice several times when I had multiple people with their transmitter switched on and a bunch of Speedlite 600EX-RT units setup for the group to control, sometimes 10 or more devices. I did send my 600EX-RT and ST-E3-RT units in to Canon for the update and never saw the link instability again. 

Brian - Canon specialist trainer, author and photographer

I wish I could say this was a solution for me. I changed the IDs as you suggested and unfortunately my link still dropped.  

Darn. I thought maybe I had figured it out for everyone. I’m just hoping my perceived success holds for me the next time I put the flashes through a real use case. 

Thank you for sharing! Unfortunately I tried changing the flash ID and always scan for the best channel - the link kept dropping. I realized it was happening at most of my indoor venues; outdoors the flashes usually stayed linked. 

I have since changed to Yongnuo-compatible flashes and they stay linked, even at all of my indoor venues. I find that the light isn't as consistent as the Canon flashes, but they get the job done. After months of troubleshooting, money spent at Canon HQ, and tons of frustration - I don't really care, so long as the flashes actually work!

Shoot. I’m so sorry that idea didn’t work for you and you’ve had such a trying experience. I am hopeful this continues to hold for me, but I still need to put it to the complex test of shooting a multiple flash setup at a wedding. Keeping my fingers crossed!

I just wanted to share that I shot a wedding last month... this one indoors... and with my flashes setup according to my previously explained possible solution, I didn't have any connection issues.  The wedding was in a downtown area... the ceremony in a first floor event space and the reception in a top floor event space... and I was able to remotely fire my speedlights with no dropped connections.  There was also a DJ at the reception, which can often be a source of interference.  I know a lot of people have posted since my original post that even with the manually set flash ID numbers, they are still having problems.  But I just wanted to chime in that so far the solution seems to be working for me.

This solution makes a lot of sense, and good idea to have custom settings anyway.  Easy to be in location with another photographer near by.  I have tried custom channel (12) and custom ID somewhere in the middle of the range.  So far it seems to hold link a bit longer, but still times out about 5 minutes.  Half depressing shutter seems to bring it back some of the time.  If that doesn't work turning transmitter off and on has seemed to relink everything.  This is far easier solution that pulling down a light stand to reset the slaves.  So my tentative conclusion this may be a workable solution.

Update: well not so easy.  Sometimes it works sometimes not.  Still had to turn slaves off and on when it really goes dead.  Very frustrating.

So now I'm experimenting with going back to the future and using the optical link instead, which generally works inside it seems.  Sure wish Canon would chime in on this one.  They have to be aware of it.


Boy does this sound familiar. I did all of the above but not sure if I changed the radio ID. I'll have to try that. One thing I noticed when I had the flashes under an rf shielding blanket. My phone still showed my wifi but not any of the neighborhood. Flashes all worked as advertised. Outside the blanket I still had link issues. So, one of my neighbors has a "dirty" wifi network. Bottom line the problem is not wifi as as a whole, just some wifi. Good to know but doesn't really solve the problem.

     As a side issue, I got a request from Canon to review the community support page. I highlighted their "non response" to this issue. 


I tried changing the flash ID. Worked well in the living room where the seating is more comfortable for testing. Moved to the garage where I do most of my shooting ( water drops.) 3 flashes worked, 1 didn't. Changed the ID twice(3000) now all work as they should. Conclusion; what works in one space may not necessarily work in another. The RF environment is very variable. Distance from router, weather conditions and probably more that I am unaware of. Be flexible. If possible do a pre-check on location where you will be shooting. Even though I have things successfully setup now, tomorrow it may not. The environment changes. I hope this helps


I want to add another report to this chain, as I've experienced the same issue with multiple units including one new unit less than a year old.

Around the beginning of 2022 I started experiencing the same behavior that PhillyPhoto described in the thread parent. Link drops between the ST-E3-RT and one or more other 600EXII-RTs, or between one or more of any combination of the 600's.This occurs on channels that the scanner shows as maximally 'good' with various IDs, in any part of the apartment.

I've tried unplugging my wireless router to eliminate the strongest known source in the apartment, it's also the only wireless device that has been updated in my apartment around the time the problem began. Everything else has been unchanged. However, I live in a dense part of Manhattan. In 2021, I used the grouped flashes extensively in wireless mode with complete reliability.

I have to conclude that there's a new interference source, or new form of interference, that causes the RT radio to lock up. As you've all experienced, I expect, once the link light goes red, you must power-cycle every unit to bring them back up. It would have been nicer if the RT radio component accepted the interference and recovered on its own.

To validate that the issue wasn't in the flash units themselves, I placed them in the microwave oven and observed that they remained linked until one unit hit its auto-power-off limit. 

I don't see a lot of discussion about this problem on the general Internet, so I have to conclude that it's just beginning to become a problem with the RT system in some areas. 

If you've stumbled upon this thread from Google, and are experiencing the same technical problem, please chime in on this thread.

In the meantime, I'm using the classic infrared RT mode, which gets the job done, but when one pays such a premium for Canon hardware, one expects to have full functionality. Fortunately they left the infrared mode intact, else I'd have no workaround.