Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

122 REPLIES 122


I have a LOT of wifi and home automation running over 2.4GHz and nothing interferes with the 600EX-RTs except the Apple Home Pods. I've pulled out the Home Pods for the last few days and today, by pure coincidence, I tested with a great deal of this stuff actually between the transmitter and slaves with no link problems at all. It's probably jus bad luck if you find a situation with a device that interferes, but you have no control of the situation and on a paying job would be a real pain. It's also unlikely that anyone at Canon will be able to reproduce the issue unless they also have such a rogue device in the building.

After receiving my Yongnuo flash I read reports that the light has a slight magenta cast. I haven't checked this out yet, but if it does prove to be a problem I'm thinking it might be correctable with a 1/8 green gel or similar.


I have been "trying" to use an ST-E3-RT (v2) transmitter and 4 600exII-RT flashes. They all connect at first. After the 5 minute timeout, some reconnect, varies which ones, and how many varies. Without having any kind of repeatability it is very difficult to troubleshoot. I turned off my wi-fi router but that didn't help. But there are lots of wi-fi in the neighborhood. I spent considerable time troubleshooting with Canon about this and they said it was the transmitter. Got a new one, same result. If there is a short time between shots, less than a minute, all works great. Once the timeout happens, everything goes to crap. Hopefully there is a genius in here that can give some guidance. I prefer not use infrared.


UPDATE: I went to a totally dead wi-fi zone this morning. Flashes and tx worked as they should. Timed out after 5 mins. and reconnected when I pushed test flash on the tx. I shoot water drops in my garage. I can shut down my wi-fi but I can't shut down the neighborhood. Other than building as RF shield in my garage, anybody have any suggestions? Does Canon even care?


Here is some info which you may or may not, find helpful. I made a "tent" of rf shielding fabric for me, flashes and the transmitter ( Under the fabric the flashes all worked as they should. With auto shut off on they all came back after hitting the test button on the transmitter. With auto shut off off, the flashes held link for over 10 minutes. For most of you this is not a practical solution. All it does is prove that wi-fi networks interfere with the flashes and transmitter. Interesting caveat; my network showed up on my phone under the tent, but didn't interfere with flash operation. One of my neighbors has a "dirty" wi-fi signal. The only way this will get resolved is if Canon takes note and investigates the problem. Until then, good luck to all

Excellent idea. Thanks for the suggestion. May work in studio setups.


Thank you, for the link for this RF fabric. I hope this helps. My flashes keep dropping at weddings, so I am eager to order these and see if it helps. 

Remember the flashes and transmitter all need to be under the fabric. Don't see how it could possibly work at a wedding. What we need is a transmitter that works on optical as well as rf


TL/DR: I think I've found the SOLUTION.  Scroll to the end... Involves changing flash ID, and also possibly radio channel.
I recently had this issue for the first time at an outdoor wedding I shot.  I thought it was the DJ's equipment causing interference and so I tried both Auto radio channel selection as well as manually forcing the flashes to stay on the same channel.  I still had the wireless link constantly dropping and the only solution was to turn them all off and back on again and force the re-link.  I was using an 600 EX II-RT on-camera (master), and then slaves off-camera were a 600 EX II-RT and a 430 EX III-RT.  This was my first time using all 3 flashes in this way... for years I had just used the two 600s without issue.  I could never figure out what the problem was, so I just kept thinking it was the DJ's setup.

Recently, I was shooting in my house and I was using just a 600 on-camera and a 600 off-camera and I had the same dropped link issue.  At this point, I was getting concerned because this 2-flash scenario had never failed me before.

So I started diving into my custom function settings again and reading online to see if there was something I was missing or if something had changed.  But everything seemed set right for my preferences and for this type of shooting.  I started messing with different configurations with all three flashes (changing channel selection, changing auto-sleep settings, changing order of how I turned everything on and off, etc, etc), and mostly what I ran into was this: when my on-camera flash would go to sleep and my slaves stayed on, if I woke up the camera and master flash again, the only flash that would relink to the 600 EX II-RT master was the 600 EX II-RT slave... the 430 EX III-RT would stay unlinked.  One possible solution looked to be turning off the auto-sleep function on the master, but I hated to do that because a lot of times I do shoot with one flash and I like for it to auto sleep to save battery power.  Besides... this seemed like a hack solution and didn't really get to the core issue that when the master powers off, one or both of the slaves don't relink.  

SOLUTION!!  (I think!)  After all the fiddling around and resetting things back to what they were when it didn't make a difference, the answer seems to be changing the Flash ID number (the 4-digit number shown under the radio channel setting).  Pretty sure most/all of us have never before thought to change that, not really knowing what it did, and so we've all only ever shot with our flashes on the default 0000.  Sometimes when we have had link issues, we've gone from Auto Channel to a set channel and that seems to fix things... which can be true if another shooter is using a different channel or there is in fact DJ interference.  But at home, by myself, channel interference issues didn't seem to be the source of my delinking because I could use Auto or force a channel and still lose the link to the 430 slave (and sometimes the 600 slave).  But once I changed the ID on all 3 flashes to the same number that wasn't 0000, I was able to maintain a link between ALL 3 flashes.  Even when my master went to sleep and I woke it up, both slaves relinked when only the 600 slave would relink before changing the flash ID.  I turned my master off completely and turned it back on and all 3 relinked.  I turned wireless transmission off and back on on the master and all 3 relinked.  I fired test shots and changed modes and turned flash firing off and on and a bunch of other settings and the links held.

So I thought that was it... setting flash ID had resolved it.  But then I did encounter a time where, after my master went to sleep, I lost the link to the slaves and couldn't get it back upon waking the master.  At first, I could at least get the 600s to relink to each other... but this time, neither of the slaves (600 or 430) relinked to the 600 master.  So then I went in and manually set the channel as well so that they were all the same on all 3 flashes, as well as maintaining the custom ID I set previously.  Then I left everything on and sitting for a long time.  The camera and master flash went to sleep.  The slaves reached their 1 hour auto-off time.  I woke up the camera and master 600 and then turned the slave 430 back on and it relinked instantly.  (The slave 600 had completely died.)

So I encourage everyone try changing the flash ID number (from 0000 default) and let me know if that fixes things for you too!  As for Auto Channel or manually set Channel... needs may vary depending on interference encountered.  I still have to see how this holds in a real shoot or wedding scenario, but I'm optimistic about this solution. 

This sounds interesting, and may be why I've not experienced the issue with the dropped links like others in the forum. 

From day 1 of owning my first pair of 600EX-RT and an ST-E3-RT way back in 2012, I changed the ID from the default 0000. I once worked out that the most awkward - needs the most button presses - is to use 5555 as the ID. The reason was that I did some demonstration photo shoots on photo shows, and I wanted to reduce the chance that a person in the audience would be able to control my lights, knowingly or not. 

As all units leave the factory with the ID set to 0000, therefore by default any Speedlite or transmitter owned by anyone has a 1 in 16 chance (15 channels plus auto) of being on the same channel and ID as you, if you use ID 0000.

Add in that the earlier Speedlite 600EX-RT and ST-E3-RT units had a firmware update that needed them sent in to Canon as they were prone to dropped links and general instability when working with more than 6 or 7 devices. I ran some Speedlite workshops, and saw that issue in practice several times when I had multiple people with their transmitter switched on and a bunch of Speedlite 600EX-RT units setup for the group to control, sometimes 10 or more devices. I did send my 600EX-RT and ST-E3-RT units in to Canon for the update and never saw the link instability again. 

Brian - Canon specialist trainer, author and photographer

I wish I could say this was a solution for me. I changed the IDs as you suggested and unfortunately my link still dropped.  

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.