Canon Community Canon Community

Occasional Contributor
Posts: 7
Registered: ‎12-30-2018
Accepted Solution

Camera Connect App not working

A month ago I got a new Apple 8 with IOS 12 on it.
I got it Connected to my EOS 70D and had it working.
It was not always connecting easily but it would connect.
Today while trying to download pictures on a holiday it won’t connect.
At first it Connected but only showed about 6 pictures.
When I selected a picture to view and download. After waiting a minute or 2. The picture was still blurry and could not download.
I tried reboot on phone and camera. This time it just showed black squares where the picture should be.
I have now deleted and tried everything but cannot get the App to connect to the camera.
When I go through the App setup I can assign the SSID and the camera shows the connection but stays on that page and never completed the configuration with the phone.
There was a recent update on my iPhone and there is a selection which leads me to believe there was an update to the app.
Product Expert
Posts: 70
Registered: ‎05-22-2018

Re: Camera Connect App not working

[ Edited ]

Hello Toodyt, 


In this type of situation it sounds like a good idea to establish a fresh connection between the camera and phone. Before starting a new connection I recommend a couple of things. I would first uninstall the Canon Camera Connect App from your smartphone, reboot the phone, and then re-install the App. This will make sure the the App is completely uninstalled and latest version of the App is installed fresh.


I would then go to the Wi-Fi option in the 3rd Setup (yellow wrench) section of the camera's menu, and set Wi-Fi to disable. After disabling the Wi-Fi turn the camera OFF then back ON. Now go back to the Wi-Fi option in the menu and enable it.


Now select the Wi-Fi function option in the menu and choose the Connect to smartphone icon to begin the connection again. If the Connect to smartphone screen shows "Choose Set." and "Review/Change settings", pick the review change settings option to go through the setup process again. If the Connection method screen appears choose the "Camera access point mode" option and proceed through the setup instructions on the camera. 


This information can be referenced in the Wi-Fi function instruction manual for the 70D HERE.


If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Occasional Contributor
Posts: 7
Registered: ‎12-30-2018

Re: Camera Connect App not working

Thank William!
I know when I was having a problem I did delete the App and reboot the phone.
I thought I had deleted the WiFi settings on the camera as well.
I did delete the App and reboot the phone.
Then I deleted the WiFi settings on the camera and rebooted it.
Installed the App and setup the WiFi connection on the camera.
It Connected as soon as I started the app and all is good!
Thanks again.
New Contributor
Posts: 1
Registered: ‎03-25-2019

Re: Camera Connect App not working

I have a G7x mark 1 and and iPhone SE running iOS 12.1.4.  Camera Connect has been working fine for at least a year but has now stopped working (possibly with the latest iPhone OS upgrade). Now the iPhone recognises the camera WiFi in settings but the camera will not find the iPhone. I have been through the business of deleting the app, rebooting the phone and reinstalling the app (2.0.0) and also 'resetting' the WiFi on the camera it still will not connect. Help please. This has been a very useful app and I am dismayed that it now does not work.

New Contributor
Posts: 1
Registered: ‎06-30-2019

Re: Camera Connect App not working

I am having a similar problem with my M50. I’m trying to download a video to my device and it keeps showing the error message that I don’t have sufficient space on my ipad when I practically have triple of what the video needs. I’ve done all the steps you suggested to Toodyt but it still isn’t working. 

A month ago it was working fine with my Rebel t6i but now it just doesn’t want to work no matter what I do. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement