Showing results for 
Show  only  | Search instead for 
Did you mean: 

XC10 Cfast error


Hello. I just purchased a used XC10. I bought a new Cfast card - SP Cinema PRO Cfast 2.0 256 GB - from Amazon. When I try to initialize the card I get a message saying "process terminated with error." Is that card not compatible with this camera for some reason or could I have a bad card. I have never used cfast cards before in any of my other cameras.


Thanks for any help.


Product Expert
Product Expert

Hi mikebmiller,


Thanks for checking in with us.


We aren't able to test every memory card on the market, but in theory your XC10 should be able to work with any reliable Cfast 2.0 card. Check to make sure that the card is firmly seated in the slot and that the memory card door is fully shut.


It might also help to see if you have the latest firmware, which is You can find the latest firmware update for your camera by going to


On the new page that loads, click on DRIVERS & DOWNLOADS link on the top right. Enter your camera model in the prompt, select it from the options that load under the box, and then press the GET DRIVERS & DOWNLOADS button.


Click the FIRMWARE heading, select the firmware appropriate for your operating system, then follow the on-screen instructions for downloading.


After you've downloaded the file, you'll want to extract it. On a PC, you'll want to right-click the file and select EXTRACT. On a Mac, it will give you a file that looks like a white drive. Double click it and drag the .fim file inside onto your desktop.


The extracted folder will include instructions on how to do the update, but let us know if you run into issues with the installation.

Nick - 


Thanks a bunch. I did the firmware update, but no luck. I guess I need to try another card.


Has anyone tried one of these?




Looks like a great way to get around the high cost of Cfast cards.


[Commercial link removed.  Replaced with screenshot to facilitate discussion.]

I got a Sandisk card and it worked perfectly.

Hello. I have exactly same issue with XC10 after I did update firmware to Card has bee working fine since camera purchase and before this update.
Using Transcend CFX650 (256GB) CFast 2.0. Card seems to be ok when I check it with card reader with pc/mac, but with camera initialization I get error: ”Process terminated with error”. I have also tried Transcend tool to ”deep format” the card with no luck.

Is there way to roll back firmware update? Asking this because I got this issue just right after the update.





What model of Sandisk did you get? Thanks.

I am also interested in if this works, so have you Mike or anyone else tried this?
At Zitay they answered when I asked about real compatibility with XC10:

"Thanks for your inquiry, the card cover of your camera cannot be closed when using the cfast to ssd adapter. Please test whether your camera can work with the card cover open. If it works, the adapter can be used."

So is there a way to use XC10 with card cover open?


I have the same exact issue. I bought:


The card description said it was compatible to the XC10. So, I researched and downloaded the new firware and it still didn't work.I returned the card because I couldn't get passed that error. I'm waiting on a different brand card and will try one last time.

[Commercial link removed per forum guidelines and replaced with screenshot to facilitate discussion.]

Hey, sorry to hear that you have same issue.

I didn´t find any solution. No answer from Canon.
Another Cfast card that I bought, did not also work. Same issue. these CFast cards are pretty expensive, my solution was external SSD.
I bought "Zitay cfast to SSD" adapter that was mentioned here before. It is working fine. Downside is that  card slot hatch is open with this adapter. You have to tape something to hatch "hole", so camera does not warn that hatch is open. This is ok when filming with camera is on stand but if you film outside by hand, then it might be issue.

My another solution was to buy Atomos Ninja V. It is also great.
I have also been looking another camera, not Canon this time. Mainly beacuse XC10 has fixed lens. 😉

Thanks for the information!

Enter for a chance to win