Showing results for 
Show  only  | Search instead for 
Did you mean: 

C70 Firmware grey'd Out


Hey All, Stoked just picked up a c70, and have not shot a thing with it yet. I'm trying to get all of the firmware up-to-date - it went to Canon to grab the latest update, and found a tutorial on youtube on how to do an update, but when I go to select camera Firmware, hoping to get the update option off the card, the camera firmware is greyed out. so I thought maybe it's too big of a step from .1 to .8 so I found firmware all the way back to 1.1 and it still won't work. It's probably something stupid I'm missing, but any pointers anyone else had this issue with their c70? Thanks!



Unless called out in the instructions, you don't have to install intermediate versions of firmware.

Can you better describe as to what is disabled?  Note that you're speaking to the OK button, you have to move the selection to the OK button.

Note that applying firmware to the C70 will erase all settings, so if you've already set up the camera to your liking, save its settings to an SD card for later retrieval.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Thanks for the response Ricky - I was able to figure it out, it ended up being my SD card, tried it with a new card, and worked right away...  so ready to go shoot with this beast!