Showing results for 
Show  only  | Search instead for 
Did you mean: 

Professional Print Layout software can't find printer


Hello there,


I recently purchased the PIXMA Pro-200 and while I'm having pretty good luck printing from Lightroom, general applications, I'd like to try the Canon PPL software features. I am running Mac OS Big Sur and printing wirelessly. Obviously the printer drivers are working fine. When I start up the PPL software I get a printer not found message. I've assigned a static IP address on the network for the 200 and can print from any device in the house it seems. I've removed and reinstalled numerous times, but the PPL printer add feature simply won't find the 200 no matter what I try. I'm starting to wonder if it isn't a Big Sur issue?


I'm not using the Airprint driver and have tried both the Bonjour method to set up as well as the specific IP address. 


Love the printer. Not loving the software...and the ridiculous ink scarcity. Any help appreciated...





An update that may save some people some trouble. The automated and web-inegrated setup for the Pro 200 is out of date and links to old drivers and software. I'd suggest you go to the current download page and get what you need directly rather than the install procedure:


The software that the installation link downloaded was ver 1.0 and wouldn't work. I updated to 1.2.2 from the link above and everything worked fine. Come on Canon...keep things updated.


BTW, found ink at an awesome Seattle camera store. Service was off the charts awesome. Glazers Camera.




Having same problem with my Pro Graf 300. I spent an hour and 47 minutes on the phone with support techs -- to no avail. Help!!! The odd thing is it worked the first dozen times I used it. I changed nothing ye all of a sudden the printer could not locate the computer. Go figure. It's making me crazy

I've just spent 2 and a half hours with Canon troubleshooting this connection issue. Did you ever figure out what the culprit was for yours?


I have had several issues today.

1 - Canon Print & Layout is not compatible with OSX Monterey.

2 - Canon PL is not compatible with Big Sur 11.6

3 - Trying to use my old desktop and although the Pro-300 connects in system preferences, Print & Layout cannot find nor add the printer.


2021 Macbook Pro, 2019 Macbook Pro, 2009 Mac Pro

I finally got this figured out.

Canon P&L is compatible with Monterey, but maybe just 12.0.1 and not 12.0.


I was able to get Canon P&L open after I also deleted the Application Support files and reinstalled the application.

The plugin was not showing in Photoshop until I chose "open with Rosetta"

              - Right click the Application > Get info > Check the box for Rosetta


Canon Print and Layout is now running correctly on 2021 Macbook Pro and 2019 MBP with 12.0.1 Monterey.


Still can't get the desktop app to see the printer but I'm over it. 

click here to view the gallery