cancel
Showing results for 
Search instead for 
Did you mean: 

Print Studio Pro not finding PRO-100 printer

mrswitters
New Contributor

I'm on an iMac Pro, running Big Sur. I just installed Print Studio Pro. In Lightroom, when I went to File > Plug-In Extras > Canon Professional Print & Layout, I get the following error message:

 

Screen Shot 2021-10-24 at 6.28.48 AM.png

 

When I click "Find Printer", no printer appears in the selection window.

 

I have the driver installed properly:

Screen Shot 2021-10-24 at 6.29.20 AM.png

1 ACCEPTED SOLUTION


@mrswitters wrote:

I'm on an iMac Pro, running Big Sur. I just installed Print Studio Pro. In Lightroom, when I went to File > Plug-In Extras > Canon Professional Print & Layout, I get the following error message:

 

Screen Shot 2021-10-24 at 6.28.48 AM.png

 

When I click "Find Printer", no printer appears in the selection window.

 

I have the driver installed properly:

Screen Shot 2021-10-24 at 6.29.20 AM.png


I don't believe PP&L is compatible with the Pro-100. 


And there is a bug with Big Sur 11.6 and PSP. 

 

I print directly from LrC to my Pro-100. I never found PSP useful. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

View solution in original post

1 REPLY 1


@mrswitters wrote:

I'm on an iMac Pro, running Big Sur. I just installed Print Studio Pro. In Lightroom, when I went to File > Plug-In Extras > Canon Professional Print & Layout, I get the following error message:

 

Screen Shot 2021-10-24 at 6.28.48 AM.png

 

When I click "Find Printer", no printer appears in the selection window.

 

I have the driver installed properly:

Screen Shot 2021-10-24 at 6.29.20 AM.png


I don't believe PP&L is compatible with the Pro-100. 


And there is a bug with Big Sur 11.6 and PSP. 

 

I print directly from LrC to my Pro-100. I never found PSP useful. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic