Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon pro-100 firmware upgrade from 1.1 to 2031


I havent been using my printer so i haven't been doing my firmwares updates like i should.  I missed 1.2 and 1.3, now i want to update it to the latest firmware and it keeps giving me an error.  I have tried my windows 10 and windows 7 and  both are giving me the same error while updating the firmware.   it shuts down the printer mid way and says it cannot connect to the printer.  no data transfers.   drivers are installed on the computer and it works, and it can print.  i just want to update the firmware.  If someone can kindly help me with this, thank you in advance.

111 REPLIES 111


Same here. Tried to update from 1.1 using a macpro running os 10.13.6 and a surface pro 6 windows 10. No luck.



I have the same problem as every one else here. I have two Pro 100s in two locations. One was purchased in Canada and the other in Brazil (a few years later). Neither will update.

Same problem here - upgrading from 1.100 to 2.031 via IMac running Catalina.

Product Expert
Product Expert



Our support group would like to collect more information about this issue.  At your convenience, please contact our phone support group at 1-800-OK-CANON (652-2666). 


Thank you for your patience with this matter.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hello everyone,


I called Canon in reponse to the post yesterday evening by Michael a Product Expert.


I was told by a different Cannon tech that nothing can be done until they can get back in the building to do the testing.


I'm not sure why someone from Canon would post the message knowing that nothing could be done.


Have a great day,



I also find the Canon response to be extremely odd. Why don't they just try the upgrade on one of their printers and figure out why it doesn't work for them? It doesn't seem to update for anyone. I have Pro-100s in Canada and Brasil, and neither will update. So it looks like the issue is not restricted to any one region.

It's definitely not true that "It doesn't seem to update for anyone." I and several others in this and related threads have reported that the update was successful and went smoothly. Please read all the posts regarding this issue and you'll see the success stories.


I have a strong feeling that this is a classic case in which only the users having problems with the update are coming to these forums and reporting them, whereas a gazillion others had no problem at all and therefore never bothered to visit here. It's human nature for the problem reports to pile up and the success stories to stay silent, but it can give a very slanted impression.


I have no idea why it fails for many owners, but it does NOT fail for everyone. My PRO-100 is living proof.



larryc - was your starting firmware 1.1 or a 2.0 series?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

I updated from Version 1.1.



All note: Larry is running 64 bit Windows 10 - see two posts on page 1 of this thread

click here to view the gallery