Showing results for 
Search instead for 
Did you mean: 

where is the WPS button?

New Contributor

Just got a Canon PIXMA MX432 and trying to set up.  It asks for me to push the WPS button, but can't find?  Hep?

134 REPLIES 134

New Contributor

Not only do the instructions refer to a button that doesn't exist in the majority of cases, but the "more options" message is displayed OVER AN ASSIGNABLE BUTTON under the LCD display. Why didn't Canon use THAT BUTTON to provide access to a proper setup screen?

New Contributor
Where is keypad

Hi Pattiblanton,


What is the model of Canon printer that you own?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

New Contributor
Well. It is now 2016 & the instructions are still the same. So THANK YOU for your tip! I have no WPS button on my old router & was going nuts trying to get the printer to recognize the wifi. Once I used your instructions I was able to get it going. Canon, don't you know a lot of laptops don't have CDs (aka cup holders) anymore?

New Contributor
I need the standard wps pin for my MX470 printer

New Contributor

The WPS button is on your modem.  In front will be WPS, push and hold it in for about 10 seconds.

Thank you. Got it. 

Also Canon printer provides option to enter password for wifi access. I think I will use this option in future for wireless printing. I just entered my wifi password and wahlaa, it worked.

New Contributor

The WPS button is on the modem or router.  Either you bought one (the cheapest way in the long term) or your internet provider hooked one up.

No. This is some proprietary option that may have existed on a few routers at one point. I've had the two latest generations of Time-Warner-provided modem/routers and they don't have this button.


There's no excuse for Canon's continued waste of customers' time with this inaccurate (and poor to begin with) documentation, and defective menu design on the printer itself.