cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

randomly won't connect now

cdallabetta
Apprentice

Canon PIXMA MG3520 running on mac, OS Mojave 10.14.6

 

This printer was printing fine. then I had to load new ink.

 

It randomly stopped printing magenta and then out of no where won't connect. my computer and printer were both on the same network. 

 

I go to printers, add...and it just won't find the printer now at all. nothing pops up. I tried holding down the wifi button on the printer. nothing. I tried holding down the stop button. nothing. I have restarted the printer so, so many times.

 

I can't figure out where to go from here. it's almost like I need to start over but don't know how. I have downloaded the most recent drives/software from the canon website. NOTHING.

 

I would honestly just buy a new printer at this point, but I just bought the ink!

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

I reccommend you confirm your printer is connected to your wireless network.  Have you verified this?

 

Canon Knowledge Base - Wi-Fi Set Up Using Cableless Method - PIXMA MG3520 / MG3522

 

Once done, confirm its IP address...  now use that to add the printer (as an IP printer) to your Mac 

 

Follow the steps in the article above, selecting your OS for more details.  Note, if one or more failed instances of the printer exists on your MAC, you may want to remove those prior to performing another installation attempt.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

This did not work and I think it's because I'm on Mojave?

 

I do the steps and there's a link to click if you are running mojave. I go to that page, it says it's compatible, and I even updated the drivers/etc (again).

 

I go back and get to the download button, and when I click the "setup" icon nothing happens.

This literally makes no sense because it was working fine before I installed new ink cartridges.

Hi cdallabetta,

 

Please press and hold the STOP button on your printer until the Alarm lamp flashes 15 times, then let go of the button.

 

On that page that printed, please take note of what is listed next to SSID.  That is the name of the network that your PIXMA MG3520 is connected to.

 

Also, please look at Signal Strength, 6 lines below SSID.  This number should be above 70%.

 

Lastly, please take note of the IPv4 IP Address, 2 lines below Signal Strength.  Open a web browser on your computer and enter the IPv4 IP Address in the address bar of hte web browser.  Are you able to access the remote user interface of your PIXMA MG3520?

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Avatar
click here to view the gallery
Announcements