Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF644Cdw Airprint name keeps changing


I have a MF644C and about every week or so the Airprint name changes. This prevents me from printing via my Macbook Pro until I delete and re-add the printer. Under "Settings/Registration: Preferences: Network Settings > AirPrint Settings" I originally set the Printer Name to "Canon MF644C", then it suddenly changed to "Canon MF644C (dd:ed:b5)" and most recently changed to "Canon MF644C (dd:ed:b5) (dd:ed:b5) (7)". I really don't care what the name is, but why does it keep changing?



Nothing is changing.  What you are showing us is a host name.  Its remaining consistent, but for whatever reason on your MAC (computer) a new instance is being created.


Example MF644C (dd:ed:b5) which is the host name of the printer, appended with the last 6 digits of it's MAC address. 


This name is being duplicated which is why you are seeing (1) ~ (7)..  will be (8), then (9) at some point. 


This issue is likely being cause by the method you have used to add the printer to your machine or how you are initiating a print job.


Are both devices connected to the same network, or are you attempting to connect directly to the printers web server?


Knowing what OS you are running, how your devices are connected and being used, including the applications you are printing from might help us better understand your environment.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


Hi fcrwx.


Shadowsports covered most of of the what and why of what was happening.


Canon-produced drivers are available, free of charge, at the MF644Cdw Drivers & Downloads page.  Try installing the Canon-produced drivers, removing the current entries for the MF644Cdw in the System Preferences >> Printers & Scanners list. Next, add it back as a new printer (if you get a context menu, select Add New Printer or Scanner to open the Add window).  Ensure the Use Driver drop-down is set to the Canon driver entry (UFR or UFR II).


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I don't think this is a hostname issue. The Airprint name displayed in the remote management console is actually changing on its own. When I log into the remote management interface and navigate to "Settings/Registration" > "Network Settings" > "Airprint Settings" and check the value for "Printer Name" I see these names that are suffixed with multiple copies of the final three octets of the printer's MAC address.


I'm on the same home WiFi network and I am only attempting to print via Airprint. I'm mostly printing from Mac OS X and iOS.


When the Airprint name changes, then I can no longer print to the already configured printer in the OS because the name has changed. Jobs in the print queue hang while trying to find the (now renamed) printer. I have to delete the printer then re-add it via Bonjour. Then it works fine again until the the next time the Airprint name changes.


The printer has a DHCP reservation.


Since I'm using Airprint, I do not need to use the Canon drivers:

Hi fcrwx.


You're free to use the Airprint drivers if you wish.  They are produced by Apple, and may have limitations of which Canon is unaware.  Since we at Canon produce our own drivers for this model's use on Mac OS, we are unable to support Airprint-related issues on Mac OS.  For support with Airprint drivers, you will need to contact Apple's support (non-Canon link:


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

It's not a driver issue. The issue is that one of the settings in the Remote UI keeps changing. Once I make a change to the setting, it should remain the same.

Hi fcrwx


If the name keeps changing, try disabling the mDNS function on the printer:


  1. Start the Remote UI and log in to System Manager Mode.

  2. Click [Settings/Registration] on the Portal page.

  3. Click [Network Settings].

  4. Configure DNS settings.

  5. Select [IPv4 Settings]  [Edit].

  6. Uncheck "Use mDNS".

  7. Click OK to set and save the change.

Note:  If the mDNS function is enabled, it will take priority over the Bonjour/Airprint name set in the other section of the Remote UI.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I have the very same issue as fcrwx.


I tried the hint suggested by Darius to uncheck mDNS in IPv4 and that certainly does not solve the issue. It disables the mDNS completely meaning the printer is now not visible from any Apple device. So I reenabled the setting again.


We need a proper solution to this anoying issue.

Usually, the name changes after the printer is switched off and started back again. 


I have the same issue.  The printer works fine on my windows system, however my 3 kids have Mac's and have been trying to print.  Everyday they have to add a new printer to their laptops and delete all the old ones.  They also have to try multiple times from their iPad's until it prints.  Very fustrating

Yes, one way to workaround it is to delete the printer from the client settings and add it again. But you have to repeat this process on all your clients/Macs... What works for me is go to the printer setup page and delete those extra characters in the brackets added to the printer name. It means revert the printer name to the original. Then you need not change anything on the clients/Macs/iPads. Hope it helps until we get the proper solution