cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS LBP6230dw Driver download not compatible with Mac Big Sur

JoeZabel
Apprentice

I have imageCLASS LBP6230dw - Wireless, Compact, Duplex Laser Printer, purchased March 2019.  I upgraded my iMac to Big Sur V.11.7.  Now the printer is still printing images, but won't print text.  I went to download the driver to the Big Sur version, however my iMac is saying the downloaded driver is incompatable and is 32-bit instead of the required 64-bit.

Is this printer model out of support?  I thought about loading a prior version of the driver, but this risks completely disabling the printer. Any help appreciated!

1 ACCEPTED SOLUTION

Hector
Product Expert
Product Expert

Hello JoeZabel,

You can download the UFRII LT Printer Driver Ver.1.5.9 from our Canon support site using the link HERE. The driver is compatible with Macs running 10.11.6-12.5.1. The driver install should work in a 64 bit environment. If you are getting any incompatibility messages during the install, I would suggest contacting support at 1-800-652-2666. They can assist with the install and see what issues the Mac is having with the driver install.

View solution in original post

2 REPLIES 2

Hector
Product Expert
Product Expert

Hello JoeZabel,

You can download the UFRII LT Printer Driver Ver.1.5.9 from our Canon support site using the link HERE. The driver is compatible with Macs running 10.11.6-12.5.1. The driver install should work in a 64 bit environment. If you are getting any incompatibility messages during the install, I would suggest contacting support at 1-800-652-2666. They can assist with the install and see what issues the Mac is having with the driver install.

JoeZabel
Apprentice

Thanks, that worked!

Avatar
click here to view the press release
Announcements