cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

another computer is using the printer. no other computer....help

traveltwo
Apprentice

I am using a HP laptop.  Just upgraded to windows 8.1.  Now I get this message 'another computer is using the printer'  I have a PIXMA MG5420.  I am connected wireless.  Please help.

2 ACCEPTED SOLUTIONS

Ramona
Authority

Hi traveltwo,

 

Reinstalling the printer drivers on your computer may resolve the issue you are experiencing.  Before reinstalling, please restart your computer and the printer.  Once restarted, please click here to go to the Drivers and Software page for the PIXMA MG5420.  Once on the initial download page for your model, please do the following:


1. Verify that the operating system detected in the "OPERATING SYSTEM" drop-down menu is correct, and if it is not, please click the drop-down menu to select your operating system.

2. Next, please click on the red arrow next to the "DRIVERS" section and click the MINI MASTER SETUP file. When you do, a red DOWNLOAD button will appear. Please click on the checkbox below the DOWNLOAD button, then click the red DOWNLOAD button to begin the download. The time for the download process may vary depending on the speed of your Internet connection and the size of the file being downloaded.

Once you have downloaded the MINI MASTER SETUP file, please double-click on it to reinstall the drivers on your computer.


Hope this helps!

 

This didn't answer your question or issue? Please call or email us at one of the methods on the Contact Us page for further assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post

Michael, I followed your instructions and the printer is now working.  Thank you so much for your help

View solution in original post

45 REPLIES 45

I have a frequent issue with "another computer...". I did use the solution to stop and start printer spooling, but I have to do it for every sheet I print. 

 

Please help with a better solution.

 

I use windows10 and Pixma Pro-10.

 

thanks

Hello.

 

Troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Michael,

 

I am having the same issue with my Canon Pixma Pro-100.  The print quality is wonderful but I cannot print more than one photo without restarting my computer due to this error "another computer is using the printer".  This is a brand new printer, I have had it installed for 6 days so the drivers are up to date.  I occasionaly have the same issue with my Canon MX452 also.  both printers are set up wirelessly.  Any advise is greatly appreciated.

 

Thank you

This is how I resolved my issue with the assistance of customer support.  I am connected wirelessly to my printer.  (1) Turned off Printer.  (2) Turned off Computer (all if more than one).  (3) Unplug Wifi for 5 seconds.  Plug router back up.   Turn everything back on, and the best part was that my document was still in Que. Smiley Happy

The following reported procedure does fix the problem: Press Windows-S and enter sevices.msc. Select Print Spooler then Stop followed by Start. However, it is tedious to have to do this each time you want a print job. You can streamline the process by using a batch file. Copy the following into Notepad:

net stop spooler

net start spooler

exit

 and save as SpoolerRestart.bat. This must be run as an administrator. You can set up desktop icon to do the job by following the procedure outlined in https://www.sevenforums.com/tutorials/11949-elevated-program-shortcut-without-uac-prompt-create.html. After sending your job to the printer, double-click the desktop icon and the print job will proceed.

 

Hi, I've tried the suggestion by Crested_Grebe, unfortunately it didn't help.  We have windows 10, a Canon MG6400 series

2 laptops are connected to the printer but are rarely used at the same time.  It is a very frustrating problem as I have to restart my laptop when I want to print, it prints only one job and has to be restarted for any successive jobs and each job comes out with a spare sheet of paper following.  Any help would be appreciated very much.

OK, I had the same problem and this is what was causing my problem. When I typed printer & scanners into the Windows 10 search box it showed that I had a Canon MB5000 printer and a Canon MB5000 WS printer. I removed the Canon MB5000 WS printer (remove device option after clicking on the Canon MB5000 WS printer). After doing this I got rid of my problem and have had no other issues. I hope this works for you.

I have Canon iP8750 series and iP8750 WS showing but don't know if there's any difference between the two.

If I have a problem again I'll try removing the 'WS' one as that worked for you. Many thanks!

Even though once again this is not your printer model this canoncommunity link might help explain what the "WS" printer is.

 

http://community.usa.canon.com/t5/Printer-Multifunction-Support/What-is-the-difference-between-the-P...

Avatar
click here to view the gallery
Announcements