Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MG5420 WiFi connection problem


The WiFi (WLAN) set-up works good all day after it starts.   But overnight when the printer is inactive it looses it.  When trying to print first thing in the morning I have to re-configure it using the "Standard Setup" method which involves typing in my WiFi password (a long and cumbersome process).  This machine is new (only 3 days old) and maybe this problem will eventually go away, but it hasn't for the last two mornings.   Anybody have this problem?  If so, how to fix?  Thanks.   


Hi Hal2k,


Yea, unfortunately you can't attach a word document or a text file, just a picture or video, but the 54% you are getting can definately account for the issues you are having.  Optimally you want that number to be around 70 to 80% if not better.  If at all possible I'd recommend moving the printer closer to where the router is, but if that's not possible you can try two things, one would be to access your router settings and try changing the wireless channel that your router transmits on.  If you are in an apartment complex or if you are in a neighborhood with other people who have strong enough wireless routers their signals can be overlapping yours causing signal loss and switching to a less crowded channel will help that.  If moving the printer or the router so that they are closer to eachother is not an option, your other option would be to purchase a wirelses extender that will strengthen the connection between your printer and router.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

View solution in original post



I found a work around for this problem.  See if it works for you as well:


The problem returned if the printer is turned off and then power on again even though WLAN DRX is already disabled.
I have to toggle WLAN DRX Enable and then back to Disable to obtain IP address for the printer.  Without IP address, printer won't connect.  So my work around is to navigate to the submenu where you have access to the WLAN DRX parameter (see the first post on page 2 for direction to  navigate to this setting).  If it is Enable, change it to Disable.  If it is Disable, change it first to Enable, wait for the printer to complete the Enable process. Then go back to the WLAN DRX setting and select Disable this time and wait for the Disable to complete.  If all works out, you should see an IP address assigned to your printer when you navigate to the WLAN settings, confirm LAN settings, and print/display LAN settings.

If this workaround does not work for you, then the IPv4 and IPv6 addresses will be empty when you print or display your WLAN settings.  Once you see the IP address displayed, you should be able to connect to the printer from your PC.


Potential fix to this problem: 
I think this is a CANON printer firmware issue as if the printer power on sequence is ignoring the WLAN DRX Disable setting set by the user and use the default setting of Enable instead.  This is why the printer lost network connection when the power is recycled or the printer is idle for too long to require a network restart.

I have sent a message to Canon Tech support to fix the firmware and make a downloadable version in the support site for the MG5520 and other affected printers.  The firmware currently downloadable in the support site is very old (version 2.050).  My MG5520 printer has 3.040 firmware but the support site firmware is 2.050.  The only way to get to the latest firmware is using the firmware update from the printer menu.  However, we cannot use the wireless firmware install function from the printer because it will first reset the printer as if the printer is rebooted before it will download the new firmware.  That reset process also resets the DRX setting to default Enable and the printer will not be able to download the new firmware 3.080 because the printer now has no ip address to communicate once it is reset to WLAN DRX Enabled.  I am not sure if 3.080 will fix this issue since I cannot get to it.  If not, Canon will need to release a new version of the firmware for all affected printers that will read and use the WLAN DRX setting when the printer is turned on or reset.


I have Pixus MG7530.

Also here, the WiFi connection set up ok, but then loses connection often. I work around by each type powering off the Pixus printer and powering it back on and then it immediately re-connects -  but, annoying!

Its clearly not a router problem, as all other devices don't have this problem.


I have an MB2320 and struggled for several hours to get my network to recognize the printer.  The standard driver load steps attempt to connect the printer which failed.  I went ahead and loaded the second set of drivers anyway and suddenly the printer was recognized.  Try loading all drivers, regardless of the apparent need to connect to the network to be successful.

Every time my cable company makes changes to their Menu, my printer loses the wifi connection to all of my Apple products.
You can call Cannon Corporation and get someone to walk you through resetting the
WiFi connection.

This is for you and every one else that is losing there printer connection after a period of time.  What you need to do is set a static ip in your router for your printer.  Login to your router and dothe following:

1) Select advanced settings

2) IP address distribution

3) Connection list

4) Find your printer and edit

5) Check the box for Static Lease Type

6) Save the setting


These are the instructions for a FIOS router but other routers are simular.  This will fix your problem.  You need to do the same thing if you have a wifi thermostat.  Set a static for your device is the key.


I had exactly the same problem with a 8200 series printer. After some trying I found out that the issue is not in the printer but in the router. If the printer uses DHCP, it obtains an IP address from the router. However, this IP address is not valid forever: after some time the lease of this IP address is over, and the connection wil be lost. It is only possible to reconnect by requesting a new IP address (done by manually reconnecting to the router).

I solved the issue by entering a fixed IP address in the printer, in the LAN settings menu, select Wifi, then settings again, then advanced, Tcp settings, ipv4, IP address.

this wotks fine for me as there is no lease time on fixed IP addresses.


National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th