Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA G6020 Showing Offline


I purchased a G6020 printer 18 months ago for my Mac and Macbook Pro. The printer has worked well until recently. Both the Mac and Macbook Pro indicate that the printer is offline line. I have tried everything - unplugging the printer, doing a factory reset, rebooting the router, running the Canon set up app, etc,  but nothing works. The printer will be online for a few minutes and then goes offline. I even set up a static IP address, but that did not work.

Any suggestions?



I have a Pixma G6020 purchased August 2023, running on a MacBook w Ventura 13.5.2 and a desktop running Windows 10 Pro build 19045.3448.

I followed the Install/setup on both platforms and everything worked flawlessly. 

After not using the printer for about a week I tried to print and the printer was recognized on both machines but said "offline" while the jobs in the queue said "searching for printer" 

I restarted Both machines and printer several times and tried to print with the same result. 

I uninstalled the printer from both machines and did a clean install  after doing a hard reset on the printer - it took 8-10 attempts at uninstalling /reinstalling and going through the setup before the printer was working again. 

after not using the printer for another 2 weeks I am back in the same boat - 

the Canon knowledge base and many other websites shows the customers are experiencing the same thing and I dont see any information on how to resolve this issue once and for all .

My next step is to get a refund and a printer from other than Canon. Its a shame because Canon is highly rated 

as for setting up the printer to print from my iPhone 12 running iOS 16.6.1 forget it  - the app and the printer dont connect after 30+ attempts 




after multiple attempts to uninstall and reinstall the printer  it was working again however, it went to sleep over night  and did not wake up when I wanted to print - (yes I did reset the eco settings to sleep after 1 hour idle and AUTO wakeup) 

rather than go through the entire uninstall/reinstall process yet again , I: 

1) went to the printer settings and clicked on the IDLE/OFFLINE printer and then clicked "RESET Print System"  and OK on the prompt warning the printer would be removed. 

2)  manually turned the printer on and opened the printer set up program  

3) setup did not detect a printer and asked what type of connection : WiFI wireless

4) followed directions that said to push the "link" button on the printer and follow instructions ... 

5) the printer was recognized and connected and I was able to print

this process took about 5 minutes vs the install/uninstall sometime it works sometimes it doesn't 30 min to hours long process.

It is by no means ideal or even remotely acceptable, 

Canon do you have any insight? or where can I file for a refund?