cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem

slashmon1
Apprentice

I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159

static ip is assigned to printer.
even when I had it on dynamic it would always assign the same ip address since it was the next one in line.

I'm glad that yours is working and thanks for your insights but I really think Canon dropped the ball on this.

Another Victim, thanks for your willingness to help. Can you give an example of what a "value" looks like in the "location" setting. I'm not sure what you mean by value. A number? Any number? Any keystrokes? Something specific? Thanks.

i've tried for a week to get my canon to print wirelessly (after months of it printing wirelessly it suddenly stopped, though the wireless connection was fine). Troubleshooting with every troubleshooter available through the printer and my pc, resetting the Lan connection, reinstalling the software, turning the PC, modem and printer on and off, changing upteen settings, pulling out my hair--nothing worked although I am pretty computer literate.

I finally found these instructions -- after countless hours of searching the web. I followed each step and viola---success. Hoping and praying that it continues to work for at least a few months, heck, I'll be thrilled with more than a few weeks. Saving these instructions to a safe place on my PC for future reference.... And what the hey, I also just printed (yey!) and taped them to the wall behind my printer where my growing sheets of instructions hang out-literally!!  Thank you for this precious info. I knew it was insane to connect through the usb cord and THEN changing the connection to wireless (as instructed on the installation cd) since no subsequent change was ever being made to the printer port settings.

 

Here are the instructions I was refering to:

Reinstalling your PIXMA MX922 should resolve this issue.  To do this, please follow these steps:

 1.  Put the PIXMA MX922's CDROM in the CDROM drive.  If the welcome screen appears, exit it.  

 2.  Click on Start and then Run.  If Run is not in your Start menu, please follow these steps to add it:

     2-1.  Click Start.

     2-2.  Right click the Start menu and left click on Properties.

     2-3.  Click on the Customize button next to 'Start Menu'.

     2-4.  In the Customize Start Menu window, place a checkmark next to 'Run Command'.

     2-5.  Click OK in the Customize Start Menu window.

     2-6.  Click OK in the Properties window.

 3.  Click Browse. In the Browse window, click on "Computer".

 4.  Double click the CANON_IJ CDROM.  

 5.  Double click the folder named WIN.

 6.  Double click the folder named Driver.

 7.  Double click the folder named DrvSetup.

 8.  Double click the file named DELDRV.  If you are using the 64 bit version of Windows 7, please double click DELDRV64.

 9.  In the Run box click OK and follow the on-screen prompts to remove the driver.

Once complete, please follow these steps:

 1.  Click on Start and then Run.

 2.  Double click the CANON_IJ CDROM.  

 3.  Double click the folder named WIN.

 4.  Double click the folder named Driver.

 5.  Double click the folder named LAN.

 6.  Double click the file named CNMNPU.exe

 7.  In the Run box click ok.

 8.  Follow the prompts to uninstall.

Once complete, restart the computer.

To install the unit for use over your network wirelessly, please follow these steps when the computer restarts:

 1.  Press the <Menu> button on your PIXMA MX922.

 2.  Select Setup and press the <OK> button.

 3.  Select Device settings and press <OK>.

 4.  Select LAN settings and press <OK>.

 5.  Select Wireless LAN setup and press <OK>.

 6.  Select Other setup and press <OK>.

 7.  Select Advanced setup and press <OK>.

 8.  Follow the on screen prompts to complete the setup.

 9.  Take out and then reinsert the CDROM that came with the PIXMA MX922.  The setup program will start automatically.

10.  If the Autoplay screen appears, click Run and then Continue.

11.  Click on Easy Install.

12.  When the Easy Install screen appears, click Install and then "Use the printer with wireless LAN connection" and follow the prompts to complete the installation.

For additional assistance, there are guides that can be viewed by following this link:

http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mx_series/pixma_MX922?se...

I've reinstalled (or in other words followed these instructions) three times and it has not corrected the problem.

Hi tyson110,

 

It is recommended that you contact live technical support . There is NO charge for this call. Real time feedback of a live technical support call would be very beneficial in this case.

Please dial 1-866-261-9362, Monday - Friday 10:00 a.m. - 10:00 p.m. ET (excluding holidays). A Canon technical support representative will be able to resolve this issue faster.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have had a complex problem with two computers refusing to print, claiming the printer is offline, claiming that it's in use by another computer when it isn't - and finally printing half sheets and then starting all over.

 

My computer wizard has solved the problem; something here may help.

 

1.  Windows 10 and 8.1 appear to have had a major update and in so doing have installed generic Windows drivers to which the printer has been defaulted.  So download drivers from Canon directly and reinstall these; remove any printer in the list that shows a "WS" suffix.

 

2.  For some reason my second computer had decided it was going to try and print through the first, so the print queue got itself confused.  If you have two or more, make sure all are using the Canon drivers

 

3.  Set a fixed IP address for the printer.

 

4. You will be better off using a wired connection.  Canon printers appear to have a problem if you ask them to switch between wired and wireless or us both at the same time.  Go into the printer setup and disable a wireless connection if that's appropriate.

 

Something on the list solved my problem!

Regardless of whether the wireless printing problem/lack of connection originated from the wireless drx setting, IPv6 setting, location field not being filled out, or dynamic IP assignments being assigned by router, I am hoping that the following procedures will always solve the wireless problem. I can only provide this after going through printer offline, printer error, printer being used by another user, etc and figuring out why the LAN setting list under the printer touch screen confirm LAN Settings was not highlighted. The PIXMA MX 920/922 can be utlized using the USB port, a wired LAN/network adapter, or wireless WLAN connection.  For each method desired, the correct method (USB, wired, wireless) has to be selected in the printer touch screen: Setup>Device Settings>LAN Settings>Change Wired/Wireless and setup with that method and CANON port (within print icon on computer) coinciding with the method desired.  In each case the printer icon in the devices and printers on computer has to reflect the correct port and associated IP for that port.  In my case, the WPS and auto detect IP did not work during the setup/initialization process.  I had to go to the computer network sharing center and look at the wireless network adapter and find the IP address for the IPv4 address, subnet, and gateway because these fields have to be input manually if you use the printer touch screen and you have to manually input password for the SSID through the printer touch screen via Setup>Device Settings>LAN Settings>Other Settings>TCP/IP>IPv4.  When you print out the LAN Settings, you will see enable for either the wireless or the wired option depending on which is set on printer in the change wired/wireless printer touchscreen option on printer.  Once I knew the IPv4 settings for both the router wireless adapter and the LAN wired connection, I did the following:  I made sure that the firmware was most recent, the DRX setting and IPv6 were disabled and I went to Canon website and downloaded most recent drivers for my operating system Windows 10 with 64 bit which was automatically detected by Canon website.  I had to do this three times for each mode/method to obtain a port: USB, Wired, and Wireless and in my case even though I chose wired and then the wireless method, I had to use the USB connection cable (USB cable from computer to printer) even though I was installing the wired or wireless option  as the process did not automatically connect to the router even though the blue light was on the printer and the wireless method was enabled.  Each time a Canon Network port with IP and MAC address was created for each driver download for the specific method so I had three icons in the printers/device on computer.  You have to make sure that the port, IPv4 addresses and MAC address for type of connection all coincide.  When you update the drivers and go through the initialization process as mentioned in previous threads, once you choose the method for connection, you will have to manually change the IPv4 addresses to match the port and method which is provided in network information during the initialization process.  If the IPv4 address does change down the road, you just have to go to the printer touch screen and manually enter the IPv4 addresses if you know the port and the MAC address is still relevant.  I updated each printer icon in computer printers and devices to reflect name that includes whether usb, wired, or wireless and the IP address that originally made it work.  If for whatever reason you can not get wireless to work, you can always run a yellow network cable from router to printer, choose the wired method and still be able to wirelessly acesss router and print through the wired method if the wired method is chosen on the printer touch screen under LAN settings.  When wired is chosen the LAN setting list will be higlighted and printer printout will show wired enable and when wireless is chosen, then WLAN setting list will be chosen and the printout will show enable for wireless.  You know it will succeed when you see IPv4 addresses in the confirm LAN settings that matches the port method (Wired, Wireless) knowing each printer icon should reflect the method or at least know, you have to configure the port for the proper method you want to print via the icon in the computer printers and devices.  Again, I had to use the USB connection cable to establish both the wired and wireless connection after I knew the IPv4 addresses for each WLAN (wireless) and LAN (wired) connection. I know this is long but should work each time for not having a wireless connection

I wanted to provide a very important clarification. When you have to initialize with drivers from Canon, before you do so you must go to the canon touch screen and reset the LAN settings first then proceed to put the printer in the correct mode with the change wireless/wired.  Moreover, I found that if I go through the USB, then wired, and last wireless method it always seems to work after resetting the LAN settings remembering for each method there will be a separate IP and MAC address for the wired and wireless mode and the printer icon created has to match with canon port created and coinciding with MAC Address.  When the printer is in the selected mode either wired or wireless you can go to the associated IP address and have access to printer settings.  When you RESET the LAN settings first you don't have to manually input the IP address.  Once I had the drivers and IP addresses for each method (wired and wireless), I accessed the router directly and address assigned each IP and the MAC device to the printer for each mode (wired and wireless).  I am hoping that will resolve the dynamic IP change of router addressing, which seems to be the issue that causes the problem

I think I have come up with a work around to avoid accessing the router directly to reserve the ip addresses.  When you get a valid connection and add a newprinter, as long as you select the proper type of printer a windows system driver or WSD with WS in name will be established.  Moreover, you can add another printer icon in printers and devices using the current tcp/ip address as the port, so if the printer is assigned a new ip address dynamically, all you have to do is choose the port type and entering current ip address assigned by the router. I suspect Canon prefers their Canon type printer port, but I have tried the procedures above and they both work, noting others have commented that WSD drivers do not encompass full functionality of printer, so would still recommend you go into router and address assign working IP address after re-initialization with drivers from Canon website, AFTER, resetting the LAN settings on the printer touch screen.

 

For NETGEAR routers, the login user is: "admin" and the pwd: "password". For other routers you may be able to look online.  The solution I discovered was going to the advanced tab [192.168.1.1/adv_index.htm] for NETGEAR routers> Setup> LAN setup and assigning the current working IP address, after printer initialization, to the MAC address and name of printer, so that the router reserves the IP address for printer and does not dynamically drop or add the printer with a new ip address which does not coincide with port and IP address that the printer was previously using.  If you do have to re-install drivers and go through process, once again, make sure you reset the LAN settings on the printer touch screen; otherwise, the new port and ip address assignment will not take with automatic detecting

Avatar
click here to view the press release
Announcements