Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX922 not recognizing Cox Panoramic wifi network


Recently I changed my internet provider to Cox and started using their Panoramic Wifi router. The printer MX922 is now not locating the network. Are they compatible?



Yes.  Compatible with the 2.4Ghz broadcast. 


This might help

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Rising Star

Hi sampath267,


As long as the 2.4GHz network is enabled the printer should be able to communicate with the printer. To troubleshoot this issue, I recommend resetting the printer's network card and connecting the printer to the network via Standard Setup. The following steps will assist you:


Resetting the Network Card


  1. Press the MENU button.
  2. Press the DOWN arrow 7 times to SETUP, press OK.
  3. Press the LEFT arrow 1 time to DEVICE SETTINGS, press OK.
  4. Press the DOWN arrow 7 times to RESET SETTINGS, press OK.
  5. Press the DOWN arrow 1 time to LAN SETTINGS ONLY, press OK.
  6. The message, “Reset settings?” will appear on the screen, press the UP arrow 1 time to YES, press OK.
  7. The message, “Following is completed.” will appear on the screen, press OK.
  8. LAN SETTINGS ONLY will return to the screen, press the BACK button 1 time to DEVICE SETTINGS.
  9. Press the UP arrow 5 times to LAN SETTINGS, press OK.
  11. Press the UP arrow to WIRELESS LAN ACTIVE, press OK.

Now that the network card has been reset, the following steps will guide you through connecting the printer to the network via Standard Setup:


Note: Your networks name and password will be needed to complete these steps.


Standard Setup


  1. Press the DOWN arrow 1 time to WIRELESS LAN SETUP, press OK.
  2. If a WPS-enabled wireless router is nearby, a message will appear on the screen telling you to press the WPS button on the router, then the OK button on the printer. Instead, press and release the STOP button.
  3. Once the screen appears that has a yellow box around STANDARD SETUP, press OK.
  4. The printer will search for nearby networks. After it has finished searching, a list of nearby networks will appear on the screen. Use the UP and DOWN arrows to select your network name from the list, press OK.
  5. If your router has a password, Enter Passphrase will appear on the screen, press OK (This may be also referred to network key or password).
  6. The character entry screen will appear, use the ARROW keys to get to the character you need, press OK to select the character. By default, lower-case letters will be on the screen.
    • If you need upper-case letters or numbers and symbols, press the middle FUNCTION button below the screen. (Each time you press the FUNCTION key it will transition in the following order: lower-case letters > upper-case letters >numbers and symbols).
    • By chance, you need to delete a character, press the right FUNCTION button below DEL. CHARACTER.
  7. Once the password is in the white bar at the top of the window, press the left FUNCTION button under DONE twice.
  8. The printer will attempt to connect to the network.
  9. When the printer connects to the network, press OK.
  10. Press the COPY button.
  11. Perform a test print.

So happy I found you.  Your directions were excellent and easy to follow.  I especially liked the click five times instructions.  I am an older user, so this was amazingly helpful and now I can print again!  I didn't know that when I moved and changed internet providers I would need to reset my printer.  Duh.  Anyway, thank you for your most excellent tutorial.

I performed all of your steps and it's still not working.

Hi mohrjoy,


If there is a WPS button on your router, please try using the WPS push button method to connect your PIXMA MX922:


Please note, some routers have WPS disabled by default.  If the above method fails, please log into your router's web interface to enable WPS.  Your internet service provider can assist you with this.





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
click here to view the gallery