Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX892 Keeps losing connection when needed.


I don't have a straight USB cord for this thing, and I'm ready to go all 'office space' on it.


It'll work for a good while, but whenever we actually need it. (it will fail!)


It'll say 'Printer not responding' in the canon box.  
The 'Windows 7' box - says ' Error-Printing'.  


The Canon IJ Network Tool says - 'Canon MX890 Series Printer' - Status: Not Found - Port Name: CNB##Masked###


However I can get it to work intermittedly by... 1) abruptly, Pulling the power cord from the printer ... 2) cancelling any failed print jobs... 3) then after putting the power back in, it will accept print jobs again through the wireless network.


But of course these steps are entirely too much for my wife.

I tried to plug it - wired to the lan.  But it says I need to temporary plug it into USB which I don't have.  I can get one.



Rising Star

Hi robertkjr3rd,


It sounds liek you might have an issue with the network.  So we can try to verify this, the next time the issue occurs, try unplugging the router and plug it back in instead of turning the printer off and on.  If this works, it may indicate that there's an issue with your router.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I found a USB cable.  It actually belonged to another HP printer, but it worked.

I have a similar problem.  I just installed this MX892 a couple of days ago, and now when I try to print, I get "Printer Not Responding."  When I open the Canon IJ Network Tool, it shows the printer as "Not Found."


I power-cycled the router.  I was able to ping the printer before and after rebooting the router.  The printer display shows no error.


I tried using the "Devices and Printers" control panel to add the printer again, but Windows did not find the printer.


I tried connecting to the printer with a Web browser, but the browser did not detect a webserver.  Does the MX892 have a web interface?


What might be causing this error?

Oh, by the way, some other details that might make a difference:

The printer has a wired connection to the network.

The IP address for the printer was assigned manually.

Hi CanonLaw,


It sounds as though there is an Active connection from the printer to the router since you are able to ping the printer.  The problem appears to be the interface with the computer.


You will not be able to readd the printer using Device and Printers because the way our printers are setup through the network is using proprietary Canon software.  The PIXMA MX892 does have a web interface but it is not necessary to use this. 


You mentioned that you have the printer connected via a wired connection to your router.  I wanted to be sure that you meant a wired ethernet connection.  The printer will not be able to network scan if it is connected using a USB cable to your router.



Hi CanonLaw!


You mentioned that you have the printer connected to your router using a wired connection.  The wired connection needs to be a wired ethernet connection and not a USB cable.  If you use a USB cable, then the printer will be able to network print but not network scan.  It should be connected via a wired ethernet cable from your printer to an open port on your router.  This is the proper setup unless you use a wireless connection to your router.


Once we have it setup correctly, we can uninstall the current drivers, then reinstall using the disc that came with the printer.  Please perform the following to uninstall:


 1.  Click Start, Control Panel, then Uninstall a program.


 2.  Click on the MP Drivers, then click Change/Remove.


 3.  Follow the onscreen instructions to remove.


 4.  Close out of this window.

We can then reinstall using the disc.  Please perform the following to do this:


 1. Insert the CD-ROM into the computer.
 2. Click Run Msetup4.exe on the AutoPlay screen, then click Yes or Continue on the User Account Control dialog box.  If the User Account Control dialog box reappears in following steps, click Yes or Continue.

 3. Select which language to use with this program and then click [Next].

 4. Click Next.

 5. Click Network Connection.

 6. Click Wired Connection.

 7. Click "Next", then wait until the next screen appears.
Install the Software (Information).  Let's perform the software installation.


 1. Click Next. Follow any on-screen instructions to proceed with the software installation.


 2. When the Setup Completion dialog box appears, click Complete.

 3. Click Next.

When the serial number is not displayed on the registration screen automatically, input the serial number located on the inside right back wall of the printer.  It will be three or four letters plus five or six numbers.

 4. Click Exit to complete the installation.  Remove the Setup CD-ROM and keep it in a safe place.


 5. Solution Menu EX starts.

This ends the procedure of the wired LAN setup. 

Hope this helps!


I have this exact same problem with my MX892. Mine is successfully connected wirelessly to my access point (Linksys EA4500 router) but my laptop loses connection to it. I have to unplug it and then it can see it.


I've reinstalled the printer via the disk and still has the problem. I think I've narrowed it down to the port. Default port on install is CNBJNP_888717D8FCFC. When I use the Canon IJ Network Tool, it can't find the printer and gives me an error: "There are ports that cannot be used with their current settings. For details, refer to the [Instructions] to be displayed automatically." I then go through a manual that comes up, but it never addresses how the port should be configured.

Hi rwmoulton,


the CanonBJNP is the correct port that the printer uses.  I have seen some cases where the IJ Network will say that the port is not configured correctly even when it is, so it's not always reliable.  Since you mentioned that unplugging the power and plugging it back in does fix the issue for a short time, I would also like to know if you tried power cycling the router instead of the printer to see if that temporarily resolves the issue.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm having the same problem...with scanning. It seems to find the printer to start the scanning, the document starts feeding from the ADF, then the connection is lost.

My printer is wireless, my computer is hardwired to the router. Software was installed from CD. My 870, which died with a roller problem leaving me with $50 of unused by unreturnable ink, had no problem with the connection.

I've tried to scan from Acrobat and Photoshop with the same result.