Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX492 connected to network but can't be detected


Intro: I have had my MX492 for almost 3 years and have used it to print wirelessly on two different home wifi networks from many different devices successfully until last week. I am guessing something was changed either in my computer's network settings, my router's settings, or my printer's settings and suddenly the printer stopped working and started giving me several different errors (not responding, offline, another computer is using the printer, etc.) anytime I sent a job.


Background Info: My computer is an HP Envyx360 and I am running Windows 10 Home. I have a Realtek RTL8822BE 802.11ac PCIe Adapter. I use McAfee LiveSafe. I moved to my current apartment over a year ago and the wireless network here is Spectrum Community Solutions, which uses an individual AP in each apartment to broadcast 2.4G and 5G signals on one meshed SSID for each unit. I have no access at all to the mikrotik router settings or the ruckus AP settings so I cannot change their configuration in any way. All I can do is unplug/restart the hardware devices hidden behind a panel in my living room wall. I have looked for a WPS button but have not found one on any of the devices inside the panel, although I could have missed it. I connect to my apartment's network with a unique WPA2-PSK but I am required to add the MAC address for any device I want to connect to a list of devices on Spectrum's Device Management page specifically for my apartment's network. When I moved in about a year and a half ago, the MX492 was one of the first devices I added and somehow (I wish I could remember exactly how it worked) I was quickly able to connect it to the network and get it working on all my devices without any issues at all. Since then, everything has been fine. Until last week. I recently developed an interest in adding smart devices to my apartment to interface with my Echo Dots. While attempting to "separate" the 2.4GHz signal from the meshed network by downloading a wifi analyzer and changing various settings on my computer (I don't even remember all the nonsense I tried), I must have really messed something up. That's when I strarted having trouble with the printer. The connectivity issue first presented as the printer showing up offline, which I temporarily corrected by restarting the print spooler service on my computer, but it got worse from there. Eventually the printer stopped responding altogether to all of the previously connected devices and would not print anything from anywhere. 


What I've Tried: First, I tried undoing everything. I deleted all data on the wifi analyzer app and deleted it. I did a system restore on my PC to a week before I started messing with any of the wifi/internet/network adapter settings. I removed the MX490 series from my computer's connected devices using the control panel and uninstalled all related drivers and software. Then I reset and power cycled the router, modem, and AP. I also reset all data on the MX492. I reset the Wireless LAN settings, device settings, everything. I basically tried to reconfigure my laptop and the network back to exactly how it had been before I broke whatever I broke and then pretend the printer had never even existed. I'm not sure it worked. Once all of that was done, I started from scratch. I went to Canon's page for the MX492 and downloaded the windows setup wizard. I ran the program and followed every instruction exactly. I successfully connected the printer to my apartment's wireless network using cableless setup. Then I ran into the problem that I have been trying for 3 days to get past: even though my computer and the printer are both definitely connected to the network, the install wizard cannot detect the printer via the router. Since discovering that issue, I have troubseshooted my brains out. First, I verified that the printer is indeed connected to the network by printing LAN settings. The Network Configuration Page confirms the connection and shows all the correct information every time I print it out. I have tried finishing the Canon setup using USB connection but the router still can't detect the MX492, even though the wizard displays the printer's correct IP address and the correct default gateway. I have tried changing connection settings on the printer and on my computer's network adapter. I have restarted everything multiple times. I disabled my firewall. Since the printer IS CONNECTED to my wifi, I have tried to manually add the printer to my computer's devices, but it still can't be found on the network. I have tried setting up the printer on my Android device through the Canon Print app using cableless setup and I have tried completing the iOS version of the MX492 setup on a Macbook. I get the same exact result every time: the router cannot detect that the printer is connected to the network. 


Conclusion: Hopefully someone can give me some tips or secrets or just point out some obvious mistake I've been making for 3 days straight so I can get this stupid printer working wirelessly again. I'm at the end of my rope. If I don't find a solution today, it's probably going in the dumpster tomorrow.



Hi kelseylol.


The MX492 is only capable of communicating on a 2.4 GHz wifi connection; separating the meshed wifi network may have caused the 2.4 GHz and 5 GHz wifi connections to no longer be able to talk to each other.  This is generally also a factory setting on routers; meshing the two types of wifi is often set after the fact.


You can verify if the problem is occurring between the printer and computer or on the computer itself by attempting to access the printer's Remote UI.  If the Remote UI opens (or if you receive an Insecure Page warning), then the network is allowing communication and something on the computer is blocking the printer's communications.


If the network is not allowing cross-communication, try switching one or more devices to the 2.4 GHz connection and try the Remote UI again.


If you're able to connect to the Remote UI, try removing the printer from your Printers list. For WIndows operating systems, also uninstall the MX490 series MP Driver from the All Programs or All Apps list, then restart the computer before re-running the installation.  Ensure the computer is communicating on the 2.4 GHz wireless connection, or that the router is allowing cross-communication.  You may need to ensure services such as the Print Spooler and Windows Image Acquistiion (WIA) are enabled.


If this answered your question, please click the Accept as Solution button, so others might find the answer.

click here to view the gallery