Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator X and macOS Mojave


My father has a canon scanner Lide 110 that uses MP Navigator X.

That software does not longer work with macOS Mojave, it wont even start. That sucks.

Does anyone know of a good scanning software that works with Lide 110?

Preferably software that detects multiple photos and saves them individually as jpegs.




Here's something you can try..


Keep your MP Navigator 3.1 installed (for now)


Install the MP Navigator 4 from the link canon asia link above


go to Applications/Canon Utilities


Right click on MP Navigator 4 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the asia 4.0 version of the app supports


Right click on MP Navigator 3.1 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the us 3.1 version of the app supports


Copy the files from the 3.1 database folder to the 4.0 database folder


Now when you start MP Naviagor 4 it will launch correctly and find your scanner.


I have not analyzed the contents of these plist files so I'm not 100% sure if this will work, but the contents of the files in the 3.1 version look pretty similar to the ones provided in the 4.0 version.

View solution in original post


I understand that the Epson software is available and works with Mojave, even with older models of their printers. It is time to switch back to Epson. The clogging problems are gone and they support their customers.

Jnaa54 does your printer have th option to scan to a usb storage drive? That’s what we’ve been using. Extremely slow and annoying but it works.


Image Capture, which is supplied free from Apple, seems to work fine with scanning from my MacBook Pro. Set the printer to sharing in the sys prefs. It works with transparencies and slides. I bought and returned Vuescan once I found that Image Capture worked. Due to lack of support for my MG8220's, I will change to another brand when I run out of ink.

Mojave does not require 64 bit apps.

Only shows as a printer-unfortunately there is no option for scanner

All I did was click on the '+' at the bottom of the 'left side of Printers and Scanners' display,and added the MG5350 again and the new one then showed two buttons, one for print and one for scan.

Does that help ?

I also tried that.... the outcome was Canon MP970 printer and now the Canon MP970 series 2 printer

I know for sure that Navigator 5x app does not work with Mojave. But the High Sierra printer and scanner drivers do work -- I'm using them now. So geting into guessing land.... I'd upload the newest or at least the High Sierra drivers. I'd delete Navigator. Then I'd delete all the installed printers and scanners. Then I'd reboot the Mac and in System Preferences add the printer and scanner as new. I think that has a pretty good chance of working normally for printing and for scanning using sys preferences as folks are describing today.

That said, I'm using an MG5320. I can't speak for other models.

Thanks for the assistance, however this is the problem..... why should Canon customers have to go through this amount of effort when Canon should simply UPDATE their drivers and not abandon their customers. Personally, I’m done with Canon products.


Hey guys.  I ran into the same problem with the Mojave OS update.  But I think I found a solution, and got it to finally work.


I downloaded this updated MP Navigator here:


If you install it from the site, it won't work.  It might even freeze the MP Navigator application on your computer, causing you to hard-shutdown to get out of it.


1.)  Uninstall all MP Navigator applications from your Mac.  Delete them.  

2.)  Go to and download the updated software, and install.  


Make sure your Mac is purged of all previous versions of MP Navigator before you install the new one.  After the new one is installed, locate it inside your Mac's Applications folder, and it should work.  

I hope that helps!

click here to view the press release