cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator X and macOS Mojave

tobiaspandey
Apprentice

My father has a canon scanner Lide 110 that uses MP Navigator X.

That software does not longer work with macOS Mojave, it wont even start. That sucks.

Does anyone know of a good scanning software that works with Lide 110?

Preferably software that detects multiple photos and saves them individually as jpegs.

thanks.

1 ACCEPTED SOLUTION

robp
Apprentice

Here's something you can try..

 

Keep your MP Navigator 3.1 installed (for now)

 

Install the MP Navigator 4 from the link canon asia link above

 

go to Applications/Canon Utilities

 

Right click on MP Navigator 4 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the asia 4.0 version of the app supports

 

Right click on MP Navigator 3.1 and select "Show Package Contents"

Navigate to Contents > Plugins > Database

You will see a bunch of .plist files -- these correspond to the scanners that the us 3.1 version of the app supports

 

Copy the files from the 3.1 database folder to the 4.0 database folder

 

Now when you start MP Naviagor 4 it will launch correctly and find your scanner.

 

I have not analyzed the contents of these plist files so I'm not 100% sure if this will work, but the contents of the files in the 3.1 version look pretty similar to the ones provided in the 4.0 version.

View solution in original post

69 REPLIES 69

robp -- I don't know how you found this solution, but I'm grateful you did and that you shared it with us.  I was about to ditch my (otherwise perfectly fine) 9000F and shell out some $ for a new scanner, when I came across your post.  Thanks so much!!!

robp this solution works great, thanks for helping me get my scanner funciton back!

My MP Navigator is 5.0. Do you know if there is any work around for this Mojave issue? I don't think I could go  back to the 3.1 version of it.

 

Thanks!

THANK YOU!!! 

This did not quite work for me (running Mojave now), but I had previously been using the MP Navigator EX 1.0 with my MX310 printer/scanner (on Mountain Lion?).

I had to go digging for the 3.0 and 4.0 versions, so here are the links:

Ver. 3.1.5: https://in.canon/en/support/0200328215/2

Ver 4.0.6: https://asia.canon/en/support/0200572715/1

 

I also copied all the .plist files from my EX 1.0 application, and I didn't see it on the v.3 or v.4 .plist files. Unfortunately, the v.4 only lets me select an MX350. Hopefully this works for someone with a newer printer!

MP Navigator Scanner Settings.png

Many thanks Robp!

 

After copying the necessary plist files from 3.1 into 4.0, my MX860 is once again able to scan using Mojave.

 

This is my second round with this issue (first was when I went to High Sierra), and both times Canon was absolutely no help.

And now, given the solution you provided, I can only conclude they intentionally left us out in the cold.

 

If they were hoping this would cause me to buy a new MFP, well...  I eventually will, I suppose, but no way it will ever be from Canon.  I have a very strong aversion to turning a perfectly functional piece of equipment into e-waste.

I have a new computer using Mojave I have a CanoScan 9000F Scanner.  I have been reading that I need to have MP Navigator EX 3.1 installed before I can go to the link and download version 4 and copy the .plist. But since I have a new computer I can not get 3.1 What would you suggust for me to get my Scanner working?  I did the IJ Scan Utility and it says to connect my USB cable, it is connected.  I am at a loss as to what to do. I have read that you have help others I hope you have a solution for me.  Thank you

BRILLIANT... thank you for this workaround. This helps right now as I have a lot of slides to scan with my now elderly 9000f, and I am not yet ready to go out and replace it. I did a 1200, 2400, and 3200 of the same slide (45 sec, 1:15, 2,15 respectively), and then aligned the the image and am amazed at how excellent the 3200 is, if you have the time. I'm going with 1200 for the bulk images for web, and then bigger later.   Thank you again for getting me going again on this. 

georage
Apprentice

MP Navigator X and macOS Mojave. My father has a canon scanner Lide 110 that uses MP Navigator X. That software does not longer work with macOS Mojave, it wont even start. ... Preferably software that detects multiple photos and saves them individually as jpegs.

 

visit: official wendyswantoknow

Hi Georage,

 

I have the same scanner and it works perfectly again. Important: remove all old installations and then make a new installation

from one of these links (posted by Icgaras):

Ver. 3.1.5: https://in.canon/en/support/0200328215/2

Ver 4.0.6: https://asia.canon/en/support/0200572715/1

after a restart it should work again,

 

Best Blueberry 

Blueberry's Solution is Fantastic!!!

 

      Ver. 3.1.5: https://in.canon/en/support/0200328215/2

      Ver 4.0.6: https://asia.canon/en/support/0200572715/1

     after a restart it should work again,

 

 

Clear all old installations

Load 3.1

then load 4.0.6   ---   and you get a "Software Failed to install" message

 

but then go look for the 4.0.6 installation in Applications and run it

 

MP Navigator 4.x loads and runs

 

FANTASTIC!!!!!

Avatar
click here to view the gallery
Announcements