Showing results for 
Show  only  | Search instead for 
Did you mean: 

LBP6230dw Wireless Network Problems


When I first got this printer I did the easy setup by simply pressing and holding the wireless button on the printer to get it into WPS mode and pressing the WPS button on my Netgear AP to get it to connect. From there I had it up and running fine on my desktop, phones, and tablets.


Then one day, after a local power outage, someone in my family noticed he couldn't connect to the printer at all. So I tried printing something on my desktop to no avail. Looked into my router and saw that it was offline, despite the printer's WiFi indicator showing that it wasn't.


Alright fine, so I do the setup again. Still offline. I checked my Netgear's web panel and found that it was indeed connected to my access point, but it was not getting a DHCP address. I further checked the router itself and found it was still listed as offline (its a frontier router, so super limited in details and actions).


The next thing I did was try going through the network setup bundled with the driver. Did the WPS setup and printed out a diagnostic and found my problem:



IPv4 Settings:
	Auto Obtain:				On
		Select Protocol:		DHCP
		Auto IP:			On
	IP Address:
	Subnet Mask:
	Gateway Address:



The subnet mask is not right at all. Nor was the IP address it somehow got assigned. The DHCP range was set to and the subnet mask is The only thing right was the gateway (although I had one retry that gave the gateway of my AP address of Where'd it get those values? Is it like Windows in that it just sets whatever it wants as a local network when it can't find one? And it will continuously do this, using the same IP address.


Alright, so I figured I'd set it myself. I went through the setup to manually input the SSID and static IP. The print out confirmed my inputs and both my router and AP are reporting that the printer had established a connection with the following information:



IPv4 Settings:
	Auto Obtain:				OFF
		Select Protocol:		OFF
		Auto IP:			OFF
	IP Address:
	Subnet Mask:
	Gateway Address:



Unfortunately, both Windows and Canon's driver software cannot see this printer on the network, even when I manually put in the address. Using an old fashioned ping results in timeouts. Reboots do not help. Nothing in both my AP and router have settings that prevent static IPs or the address. I can still print to the thing using a USB connection, but that isn't the purpose of this printer.


So any ideas? Is the wireless on this thing busted or am I not seeing one detail that'll fix this?




Because no one wants to help I figured it out on my own.

Just do a factory reset. Its not in the setup or driver setup, its a pinhole button found in between the USB and Ethernet port.

Thanks for nothing.

Hi JZharay,


Thank you for posting how you resolved your issue with the LBP6230. It will help others in the forum with the same issue.


If you have a time-sensitive matter in the future, our US-based technical support team is standing by at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 6:30 PM ET.

I don't know by reading the thread whether JDzharay did the factory reset and then reinstalled the printer. I just tried all of that and my printer doesn't print. I went through reinstallation yesterday and the settings didn't hold. I just tried to call the technical support line and was told by the recording that the wait time is more than 10 minutes and then was switched to elevator music. Since I don't know how long that is and don't want to listen to that music, I hung up. It would be great if I could leave a message and get a call back.

To at least print via USB cable, I went to the Apple logo on the top left on my MacBook running MacOS Monterey and selected Printers and Scanners. I deleted the Canon LBP6230DW from my listed printers where it was displayed as In Use. I then added it and selected USB printing. Then I selected software in the menu offered by Apple for drivers. That got me printing. I don't know if it's worth trying to set up the glitchy wireless connection that previously worked well but would then fail and require me to fish again in the data toilet.


The IP address that you posted appears to be an apipa DHCP address. Basically, when your computer times out with getting an address from the DHCP server, the device self assigns an "apipa" address. If it is a wifi or network printer, it's possible the network services were malfunctioning or just became corrupted until you re-set the values. 

Typically, DHCP works in the manner I detailed below:

Client - hey, network....can I have an IP address?
DHCP - Sure how is (with subnet mask & gateway)?
Client - uhhh lemme ping it and make sure you are not giving me an address already in use.
Client - <pings address and verifies> responds to DHCP, yep looks good, I'll take it. 
DHCP - Cool Bro.  I'll mark you down in our book. 

In your case, your device did step 1. But there is not enough troubleshooting info to tell you why step 2-5 were not successful. Sometimes the network services just hang from running out of memory or cpu usage out of control. 


Are other devices on the network successfully receiving a DHCP address?