Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageClass MF743CDW having issues with initial wireless setup


Trying to install the software on my Win10 PC, I don't have a CD/DVD drive so I'm trying to install from the downloaded software. When I get to the part where I search for the printer, it never finds it. I know its connected to the 2.4ghz of my mesh network, says so in the printers settings. I have an Orbi Mesh wifi 6 setup. Outside of buying a wireless repeater, I'm not sure what else to do to get either of my PCs to find the printer. Am I missing a setting or do I have to get extremely specific on how to setup the printer or my PC? I'm not really keen on having to turn off my 5ghz band in order for my PC to switch to 2.4ghz to see the PC if thats what the issue is. Any help would be greatly appreciated before I spend $20-$30 on a repeater or have to hardwire this to only one PC in the house. Thanks to anyone who reads this or is able to help.










The printer will only connect to a 2.4Ghz network.  


Your PC being on 5G and the printer connecting to a 2.4Ghz broadcast doesn't matter.  Unless you are using a "Guest" broadcast with isolation enabled, all devices (wired or wireless) can see and communicate with one another on the LAN.  


Are you using "SMART Connect"?  (One SSID for all of your broadcasts)  If so, I would temporarily disable the 5G broadcast(s) and verify  the printer is attached to the 2.4Ghz broadcast...  don't do this on the printer.  Do it in the "Attached Devices" section in the Orbi's Admin GUI.  While you are at it, reserve an IP for the printer using it's MAC address.


Advanced tab > Setup > LAN setup...  Don't use the Orbi or nighthawk app on a mobile device...  log into your Orbi Admin portal from your PC.


Once you have reserved an IP, and verified the printer is in fact connected to 2.4 Ghz...  (meaning you can PING it) and view its websever in a browser...  you will be ready to run the installation.


The is nothing magic about the CD that comes with the printer..  in fact its outdated since it was burned when the printer was boxed up at Canon.  Now its sat in a warehouse on on a store's shelf until you bought it... Getting the latest drivers from Canon's support portal is always the best way to go.


Once you are connected, you can re-enable "SMART Connect" if you wish.  FYI I have a Tri-Bard router and use separate SSID names for each broadcast.  "SMART Connect" isn't so smart and this way I control what broadcast a device connects to.  This is a one and done, set and forget model.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thanks for the thorough step by step, but still no luck. I turned off the 5g portion, checked the attached devices and it does say 2.4g, ping the printer server. had to setup a pin for the remote UI access. But when I go to the setup and try to get it to find the device still nothing, manually entering the ip still nothing. Am I missing something?



Its attached according to the Orbi's admin portal?  What's the printer's IP address?


You can PING that IP from your computer successfully?


and it replies...


Reply from [printers IP]: bytes=32 time=2ms TTL=255


What is your computer's IP address?


Do you have a 3rd party Anti-Virus or firewall software other than Windows Security installed that might be blocking communication?


You do have to set up a PIN for remote UI management (this is normal).  Sounds like you are really close.



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Sorry for the late reply, medical issues and stuff.

Yes I did the ping test and I did get back similar numbers.

So what else could I be missing. Created the remote UI pin and can log onto the printer from a browser.

Hello TheBebop,


If you are able to ping the IP address and you can access the printer's web UI, the printer's network connection should be fine. In this situation, I would suggest turning off any firewall or anti-virus programs that could be blocking the printer detection in the setup.


If the printer is still not being detected with all of your security software turned off, I would suggest contacting our support team at 1-800-652-2666, our agents would be happy to check the network environment and check what might be going wrong with the network setup.