cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon professional print and layout will not send to print

JustJamesK
Apprentice

Hi all,

 

I hope someone can help.

Last week my canon professional print and layout software just stopped sending my images to print.  I keep getting the error " Error - please check the printer's operational panel or remote UI" in the print job screen (see image below).   

 

Lightroom & Photoshop are able to send to print but the results are very different.

 

I have reset & re-installed everything.  All software and drivers are up to date.

I'm running iMac with the latest Catilna software.  Like I said before, it was all running fine last week.

 

Anyone expereinced the same issue?

 

 

Screenshot 2020-04-07 at 12.27.52.jpg

16 REPLIES 16

Porcha
Rising Star

Hi,

 

Thank you for your inquiry, and welcome to the Canon Forums.

 

We appreciate your participation, however, for the community to best assist you can you provide us with the following information:

 

  1. Operating System of the computer?
  2. How is your printer connected?
  3. Model of printer?

 

If you are in the USA and need immediate assistance please call us at 1-800-OK-CANON (1-800-652-2666) and we will be happy to help! If you live outside the United States, to go: https://global.canon and select your country or region for your support needs.

I had the same issue and after calling Canon support and walking through it the tech found the issue.  My ISP swapped out my router a few weeks ago and the IP address space on my network changed.  PPL was still trying to send using the old IP address of the printer.  So when it adds the printer, whatever IP address it has sticks so you have to manually add it again using the new one.

 

Took a while to get them on the line but he nailed it first try.  Good job Canon tech support.  I hate that I didn't notice that but either way, it's fixed.  Hopefully this helps someone else.

 

Thanks for replying, ncsamiam.  It does look as though PPL is looking to the wrong IP address.  It won't allow me to remove the current printer, or add a new one however.  Nothing's changed on my system that I'm aware of, so this is kind of perplexing.

 

So I'll have to keep trying to get through to someone at the support number.  I tried again this morning, however had to give up after almost 30 minutes of listening to 60s era mellow jazz hold music.  Will try again later.

Yes it won't allow you to remove all the printers in the list.  When I told it to add printer, I selected "Auto" and it immediately showed it to me, albiet with a different name, and when the new entry was added I was then able to delete the old entry.  If you change from Auto you can give it a specific IP address to look for it.  Maybe try that if you haven't already.  And good luck.. I put them on hold and just left the speaker phone on while I worked on other stuff.  Odd music selection, I must say.  🙂

I finally got through to the support folks!  Had to block my calendar to allow time for it, but success!  Didn't even have to listen to the music for very long.  Smiley Wink

 

So PPL is once again working, after finding the correct IP for the printer, which was somehow different than when I originally installed the software.  I may never know what happened, but at least now I know how to correct the problem.

Would you mind sharing what process they advised you in order to fix this?

mrwalterevans
Apprentice

Have you had any resolve? I have this problem too and can't figure out what is wrong.

Hi.

I faced the same issue. What is happening is that the Software Professional Print and Lay Out (PPLO) is looking for the old printer which you can see in the tab Printer (just below stored settings on the right hand side). If you click on the printer tab, you will see two options -"Add Printer" and "Delete Printer". Press "Add printer" and select your Cannon Printer once again. Once it is registered, Delete the old one. You should be able to use PPLO software. 

The issue frustrated for a long time. Hope you too can resolve the issue with above steps.

Regards

 

eclubfoundation
Apprentice
I am experiencing this similar problem currently. I have 2 laptops connected to my printer (Canon imageprograf 4000s. This two laptops initially working fine but suddenly the two of them started having the error stated above. I have done many ways to make it work but ppl keeps bring the error message out.

Please note:
Operating system is windows 10 pro
IPrinter model mageprograf pro 4000s
PPL version 1.2
Connection method: wired network connection.


Avatar
click here to view the press release
Announcements